7-Zip Начальная страница

7-Zip

Добро пожаловать в 7-Zip 9.20!

7-Zip архиватор файлов с высокой степенью сжатия.

Документация 7-Zip включает:

  • Общую информацию о 7-Zip
  • Руководство пользователя 7-Zip Менеджера файлов
  • Руководство пользователя версии Командной строки

См. также

  • Часто задаваемые вопросы (FAQ)

Copyright (c) 1999-2010 Igor Pavlov

Вебсайт: www.7-zip.org

Поддержка: www.7-zip.org/support.html


Общая информация

Основные функции 7-Zip

  • Мощный Менеджер файлов
  • Высокая степень сжатия и высокая скорость
  • Большое число поддерживаемых архивных форматов
  • Дополнительная версия командной строки

См. также

  • Лицензия для использования и распространения


Поддерживаемые форматы

Формат | Упаковка | Распаковка | Расширения имени файла
7z | X | X | 7z
XZ | X | X | xz
ZIP | X | X | zip
GZIP | X | X | gz gzip tgz
BZIP2 | X | X | bz2 bzip2 tbz2 tbz
TAR | X | X | tar
WIM | X | X | wim swm
LZMA |  | X | lzma
RAR |  | X | rar
CAB |  | X | cab
ARJ |  | X | arj
Z |  | X | z taz
CPIO |  | X | cpio
RPM |  | X | rpm
DEB |  | X | deb
LZH |  | X | lzh lha
SPLIT |  | X | 001 002 ...
CHM |  | X | chm chw hxs
ISO |  | X | iso
UDF |  | X | iso
COMPOUND |  | X | msi doc xls ppt
DMG |  | X | dmg
XAR |  | X | xar
HFS |  | X | hfs
NSIS |  | X | exe
NTFS |  | X | ntfs
FAT |  | X | fat
VHD |  | X | vhd
MBR |  | X | mbr
SquashFS |  | X | squashfs
CramFS |  | X | cramfs

ZIP

7-Zip создает совместимые ZIP архивы. 7-Zip поддерживает следующие методы ZIP сжатия:

  • 0 - Store
  • 8 - Deflate
  • 9 - Deflate64
  • 12 - Bzip2
  • 14 - LZMA
  • 98 - PPMd
  • 1 - Shrink (только распаковка)
  • 6 - Implode (только распаковка)

Файлы, сжатые другими методами ZIP сжатия, не могут быть извлечены текущей версией 7-Zip. Но поддержанные методы являются сейчас самыми популярными, и это значит, что 7-Zip может распаковать большинство ZIP архивов. Чтобы извлечь файлы, сжатые неподдерживаемыми методами, Вы должны использовать другую ZIP утилиту.

7-Zip поддерживает Zip64 расширение формата ZIP.

Текущая версия 7-Zip не поддерживает многотомные ZIP архивы.

LZH

7-Zip поддерживает LZH архивы только для листинга, просмотра и распаковки. 7-Zip поддерживает -lh0-, -lh4-, -lh5-, -lh6- и -lh7- методы.


7z формат

7z - новый формат архива, который обеспечивает высокую степень сжатия.

Основные функции 7z формата:

  • Открытая архитектура
  • Высокая степень сжатия
  • Сильное AES-256 кодирование
  • Способность использовать любое сжатие, преобразование или метод кодирования
  • Поддержка файлов с размером до 16000000000 Гб
  • Имена файла в уникоде
  • Solid сжатие
  • Сжатие заголовков архива

7z имеет открытую архитектуру, таким образом, он может поддержать любые новые методы сжатия.

В настоящее время в 7z интегрированы следующие методы

Метод | Описание
LZMA | Улучшенная и оптимизированная версия LZ77 алгоритма
LZMA2 | Метод сжатия основанный на LZMA. Он обеспечивает лучшую поддержку многопоточности, чем LZMA
PPMD | PPMdH Дмитрия Шкарина с небольшими изменениями
BCJ | Конвертер для 32-разрядных x86 исполнительных программ
BCJ2 | Конвертер для 32-разрядных x86 исполнительных программ
BZip2 | Стандартный BWT алгоритм
Deflate | Стандартный алгоритм основанный на LZ77

LZMA - значение по умолчанию и общий метод сжатия 7z формата. Основные функции LZMA метода:

  • Высокая степень сжатия
  • Переменный размер словаря (до 4 Гб)
  • Скорость сжатия: около 1 Мб/с на 2 ГГц-м процессоре
  • Скорость распаковки: около 10-20 Мб/с на 2 ГГц-м процессоре
  • Маленькие требуемые объемы и конфигурации памяти для распаковки (зависят от размера словаря)
  • Маленький размер кода для распаковки: приблизительно 5 кб
  • Поддержка многопоточности и P4 с hyper-threading

Алгоритм сжатия LZMA является наиболее подходящим для вложенных приложений. Если Вы хотите использовать код LZMA, Вы можете получить консультации, заказать программный код и требуемые лицензии разработчика на

www.7-zip.org/support.html

7-Zip также поддерживает кодирование с AES-256 алгоритмом. Этот алгоритм использует ключ шифра длиной 256 бит. Создавая этот ключ, 7-Zip использует функцию образования, основанную на алгоритме SHA-256 смешивания. Функция образования ключа производит получаемый ключ из текстового пароля, определенного пользователем. Чтобы увеличивать затраты времени для полного перебора паролей 7-Zip использует большое число итераций, чтобы создать ключ шифра из текстового пароля.

Подсказки для выбора длины пароля

Здесь оценивается время необходимое при атаке поиска пароля, когда пароль - случайная последовательность маленьких латинских букв.

Мы предполагаем, что один пользователь может проверить 10 паролей в секунду, а организация с бюджетом приблизительно 1 миллиард $ может проверить 10 миллиардов паролей в секунду. Мы также предполагаем, что используемый процессор удваивает свою производительность каждые два года, таким образом, каждый дополнительный латинский символ длинного пароля добавляет приблизительно 9 лет для исчерпывающей атаки поиска ключа.

Результат - эта оценка времени, чтобы преуспеть в атаке:

Длина пароля | Атака отдельного пользователя | Организованная атака
1 | 2 с | 1 с
2 | 1 мин | 1 с
3 | 30 мин | 1 с
4 | 12 часов | 1 с
5 | 14 дней | 1 с
6 | 1 год | 1 с
7 | 10 лет | 1 с
8 | 19 лет | 20 с
9 | 26 лет | 9 мин
10 | 37 лет | 4 часа
11 | 46 лет | 4 дня
12 | 55 лет | 4 месяца
13 | 64 года | 4 года
14 | 73 года | 13 лет
15 | 82 года | 22 года
16 | 91 год | 31 год
17 | 100 лет | 40 лет


Выполнение

ZIP формат

Результаты степени сжатия очень зависят на данных, используемых для тестов. Мы сравнили 7-Zip с некоторыми ведущими коммерческими архиваторами: PKZIP 2.04g, WinZip 7.0.

НАБОР ФАЙЛОВ: Canterbury Corpus (11 файлов составляющие в сумме 2 810 784 байта, популярный набор файлов, используемый для оценки сжатия).

Архиватор | Сжатый размер | Коэффициент
7-Zip (zip формат) | 676284 | 100%
PKZIP 2.04g -ex | 726047 | 107%
WinZip 7.0 (Макс) | 731499 | 108%

7z формат

7z - новый формат архива, обеспечивающий высокую степень сжатия.

НАБОР ФАЙЛОВ: GIMP 1.2.4 для Windows после полной инсталляции (127 подпапок, 1304 файла составляющие в сумме 27 128 826 байт). GIMP - GNU программа манипуляции образами. Она может быть загружена с www.gimp.org.

Архиватор | Сжатый размер | Коэффициент
7-Zip (7z формат) | 5445402 | 100%
WinRAR 3.10 | 6004155 | 110%
WinAce 2.3 | 6242424 | 115%
CABARC 1.0 | 6455327 | 119%
7-Zip (zip формат) | 9461621 | 174%
PKZIP 2.50 | 9842800 | 181%

GZIP формат

7-Zip обеспечивает лучшую степень сжатия для формата GZIP. Степень сжатия равна степени сжатия для ZIP формата (выше).


Часто задаваемые вопросы (FAQ)

Я могу использовать 7-Zip в коммерческой организации?

Да, 7-Zip - бесплатное программное обеспечение. Вы можете использовать его на любом компьютере. Вы не должны регистрироваться или платить за 7-Zip.

Почему версия командной строки не добавляет файлы, которые не имеют никакого расширения?

Вы вероятно используете *.* подстановочный знак. 7-Zip не использует анализатор подстановочных знаков системы Windows; так, 7-Zip не следует тому архаичному правилу, по которому *.* соответствует любому имени файла. 7-Zip обрабатывает *.* только как соответствие имя файла с расширением. Чтобы обрабатывать все файлы, Вы должны использовать только подстановочный знак * или опустить подстановочный знак вообще.

Что относительно поддержки ACE архива?

Поддержка ACE может быть осуществлена, если исходный текст этого формата будет доступен, и если лицензия исходного текста позволит использовать этот код.


Лицензия и использование дистрибутива

Лицензия

7-Zip Copyright (C) 1999-2010 Игорь Павлов.

Лицензии для файлов:

  • 7z.dll: GNU LGPL + unRAR ограничение
  • Все другие файлы: GNU LGPL

    GNU LGPL + unRAR ограничение означает, что Вы должны следовать и правилам GNU LGPL, и правилам unRAR ограничения.

    Примечание: Вы можете использовать 7-Zip на любом компьютере, включая компьютер в коммерческой организации. Вы не должны регистрироваться или платить за 7-Zip. Читайте файл License.txt для полной информации о лицензии.


Благодарности

Я хотел бы поблагодарить:

  • myspace - за перенесение на Unix/Linux (p7zip), тестирование, исправление ошибок и другое
  • ARJ Software - за ARJ
  • Wei Dai - за SHA-256 код и Crypto++ Library
  • Jeff Gilchrist - за тестирование сжатия
  • Brian Gladman - за AES код в предыдущих версиях 7-Zip
  • Szymon Grabowski - за некоторые идеи
  • Microsoft Corporation - за описание CAB/WIM форматов и WiX (Windows Installer XML)
  • Nullsoft, Inc. и NSIS team - за NSIS (Nullsoft Scriptable Install System)
  • Robert Martinez - 7-Zip Logo
  • Markus Oberhumer и Laszlo Molnar - за программу UPX
  • Alexander Ratushnyak - за тестирование сжатия
  • Eugene Roshal - за RAR
  • Matthew Russotto - за описание CHM/CAB формата
  • Julian Seward - за BZip2
  • Eugene Shelwien - за некоторые идеи и алгоритмы
  • Dmitry Shkarin - за PPMd алгоритм
  • Yoshioka Tsuneo - за программу TAR32
  • Vadim Yoockin - за тестирование сжатия
  • Bulat Ziganshin - за некоторые идеи
  • John Michael Williams - за исправления файла справки
  • Apple Inc. - за HFS
  • vu1tur(DMG2IMG) - за DMG
  • NTFS-3G team - за NTFS

Группа локализации:

  • Afrikaans - Petri Jooste
  • Albanian - MIkel Hasko
  • Arabic - Mohammad Deeb, Awadh A Al-Ghaamdi, Ahmad Gharbeia
  • Armenian - Gevorg Papikyan, Hrant Ohanyan
  • Asturian - Dinamiteru
  • Azeri - F@rhad
  • Basque - Inigo Salvador Azurmendi
  • Belarusian - Kirill Gulyakevitch, Drive DRKA
  • Breton - KAD-Korvigellou An Drouizig
  • Bulgarian - Chavv, icobgr, Vassia Atanassova
  • Catalan - Josep Casals, Gaizka Boleko, Marc Folch
  • Chinese Simplified - Modern Tiger, kaZek, Hutu Li, Junior.Spirit
  • Chinese Traditional - Leon Tseng, sec2, Jack Pang
  • Croatian - Alan Simek, Hasan Osmanagic, Stjepan Treger
  • Czech - Jaromir Veber, Milan Hruby, Michal Molhanec, Jiri Malak
  • Danish - Jakob Schmidt, Kian Andersen, Jorgen Rasmussen
  • Dutch - Bert van Velsen, Jeroen van der Weijde, Harm Hilvers, Jeroen Tulp
  • Esperanto - Dmitri Gabinski
  • Estonian - Kaupo Suviste
  • Extremaduran - Miguel Angel
  • Farsi - Edris Naderan, Mehdi Farhadi
  • Finnish - Ari Ryynanen, Jarko P., Juhani Valtasalmi, T.Sakkara
  • French - Nicolas Sierro, Philippe Berthault
  • Friulian - Andrea Decorte
  • Frisian - Berend Ytsma
  • Galician - Xose Calvo
  • Georgian - Dimitri Gogelia
  • German - Soeren Finster, JAK-Software, Joachim Henke
  • Greek - Vasileios Karakoidas, Jacaranda Bill, Vasilis Kosmidis
  • Hebrew - Gal Brill, Jonathan Lahav, Peter G
  • Hindi, Gujarati, Sanskrit - Vinayy Sharrma
  • Hungarian - Jozsef Tamas Herczeg, Misy Nyilas
  • Icelandic - bjossi
  • Ido - iZoom
  • Indonesian - M. Rofiq Setiawan, Frans Liando
  • Italian - Leandro Spagnol, TJL73
  • Japanese - Komuro, Mick, 2chBBS-software, Stepanushkin Dmitry, Crus Mitsuaki
  • Kazakh - Arslan & Arman Beisenov
  • Korean - bzImage, ZannyLim, Hyeongil Kim (kurt Sawyer), Dong-yoon Han
  • Kurdish - Rizyoye Xerzi
  • Kurdish Sorani - Ara Bakhtiar, Ara Qadir
  • Latvian - Armands Radzushka
  • Lithuanian - Marius Navickas
  • Macedonian - Gabriel Stojanoski
  • Malay - Khairul Ridhwan Omar
  • Marathi - Subodh Gaikwad
  • Mongolian - Bayar
  • Norwegian Bokmal - Christoffer Andersen, Kjetil Hjartnes, Robert Gronning
  • Norwegian Nynorsk - Robert Gronning
  • Pashto - Zabeeh khan
  • Polish - Cienislaw, Pixel, F1xat, Lukasz Pastuszczak
  • Portuguese Brazil - Francisco Jr, Fabricio Biazzotto, Atualizado por Felipe
  • Portuguese Standard - Carlos Macao, Joao Alves, Rui Costa, Sergio Marques
  • Punjabi Indian - Gurmeet Singh Kochar
  • Romanian - Lucian Nan
  • Serbian - Lazar, Ozzii
  • Serbo-Croatian - Miodrag Jevremovicc
  • Slovak - Tomas Tomasek, Pavel Devecka
  • Slovenian - Jernej Simoncic, miles
  • Spanish - Pablo Rodriguez, Jbc25, Guillermo Gabrielli, Miguel Angel, Sergi Medina
  • Swedish - Andreas Nilsson, Christoffer Enqvist, Bernhard Eriksson
  • Sinhala - G.S.N. Supun Budhajeewa
  • Tamil - Ve Elanjelian
  • Tatar - Amychok
  • Tatarish - Albert Fazli
  • Thai - Chayanon Ruamcharoen, Kom10
  • Turkish - X-FoRcE
  • Ukrainian - Andrij Ilechko, Mokiy Mazaylo, Sergiy Gontaruk, Misha Padalka, Yurii Petrashko (YuriPet)
  • Uyghur - Sahran
  • Uzbek - Sherzod Mamatkulov
  • Valencian - Tomas Miralles, Fernando Verdu
  • Vietnamese - Tran Hong Ha, Le Vu Hoang
  • Voro - Valdis Laan
  • Welsh - Owain Lewis


7-Zip Менеджер файлов

7-Zip Менеджер файлов - программа для управления файлами и папками.

7-Zip Менеджер файлов может работать с двумя панелями. Вы можете переключаться между панелями, нажимая кнопку Tab. Большинство операций с пунктами может быть выполнено, используя горячие клавиши, или щелчком правой кнопкой мыши на пунктах и выбором соответствующей команды в меню.

В этом разделе

Пункты меню и Горячие клавиши
Описывает пункты меню и горячие клавиши.
Диалоговое окно Настройки
Описывает, какие настройки, затрагивающие 7-Zip Менеджер файлов, Вы можете изменить.
Тестирование производительности
Описывает Тестирование производительности 7-Zip для измерения производительности центрального процессора.
Диалоговое окно О программе
Обеспечивает информацию о 7-Zip.
Плагины
Описывает плагины для 7-Zip Менеджера файлов.

У Вас есть доступ к следующим элементам из корневой папки в 7-Zip Менеджере файлов:

  • Компьютер: диски компьютера
  • Документы: папка Мои документы текущего пользователя
  • Сеть
  • \\. : папка для низкоуровнего доступа к дискам. Вы должны иметь права администратора для использования этой папки. Вы можете
    • копировать .iso образ с CD/DVD в файл.
    • просматривать NTFS/FAT разделы через 7-Zip парсер. Это обеспечивает доступ (только для чтения) к файлам включая недавно удаленные файлы в NTFS разделе через папку [DELETED].


Пункты меню и Горячие клавиши

Пункты меню

Примечание: 'Grey' ('Серый') относится к цифровой клавиатуре.

Файл

Пункт меню | Горячие клавиши | Описание
Система |  | Подменю с командами меню из системной оболочки
Открыть | Enter | Открывает текущий пункт
Открыть внутри | Ctrl+PgDn | Открывает текущий пункт как папку, внутри 7-Zip
Открыть снаружи | Shift+Enter | Открывает текущий пункт в новом окне
Редактировать | F4 | Открывает выбранный пункт в редакторе
Переименовать | F2 | Переименовывает выбранный пункт
Копировать в... | F5 | Копирует выбранные пункты
Переместить в... | F6 | Перемещает выбранные пункты
Удалить | Delete | Удаляет выбранные пункты
Разбить файл... |  | Файл разбивается на части
Объединить файлы... |  | Файлы объединяются в один файл
Свойства | Alt+Enter | Показывает свойства файла
Комментарий | Ctrl+Z | Устанавливает комментарий для файла
Контрольная сумма |  | Подсчитывает CRC контрольную сумму для файлов
Diff |  | Показывает различия между двумя файлами
Создать Папку | F7 | Создает новую папку
Создайте Файл | Shift+F4 | Создает новый файл
Выход | Alt+F4 | Закрывает программу

Правка

Пункт меню | Горячие клавиши | Описание
Выделить все | Shift+[Grey +] | Выделяет все пункты
Убрать выделение | Shift+[Grey -] | Снимает выделение всех пунктов
Обратить выделение | [Grey *] | Выделяет/Снимает выделение всех пунктов
Выделить... | [Grey +] | Выделяет определенные пункты
Убрать выделение... | [Grey -] | Снимает выделение определенных пунктов
Выделить по типу | Alt+[Grey +] | Выделяет все пункты с тем же самым расширением как текущий пункт
Убрать выделение по типу | Alt+[Grey -] | Снимает выделение всех пунктов с тем же самым расширением как текущий пункт

Вид

Пункт меню | Горячие клавиши | Описание
Крупные значки | Ctrl+1 | Показывает пункты, используя большие значки
Маленькие значки | Ctrl+2 | Показывает пункты, используя маленьких значки
Список | Ctrl+3 | Показывает пункты в списке
Таблица | Ctrl+4 | Показывает пункты в списке с подробной информацией о каждом пункте
Имя | Ctrl+F3 | Сортирует пункты по имени
Тип | Ctrl+F4 | Сортирует пункты по типу
Изменен | Ctrl+F5 | Сортирует пункты по дате
Размер | Ctrl+F6 | Сортирует пункты по размеру
Без сортировки | Ctrl+F7 | Не делает сортировки пунктов
Плоский режим |  | Переключает плоский режим просмотра для списка файлов
2 Панели | F9 | Переключатель Включить/Выключить вторую панель
Панели инструментов |  | Пункты меню для обрабатывающих инструментальных панелей
Открыть корневую папку | \ | Открывает корневую папку компьютера
Переход на один уровень вверх | Backspace | Открывает папку, одним уровнем выше
История папок... | Alt+F12 | Открывает историю папок
Обновить | Ctrl+R | Обновляет список пунктов

Сервис

Пункт меню | Горячие клавиши | Описание
Настройки... |  | Открывает диалоговое окно настроек
Тестирование производительности |  | Измеряет производительность Вашего компьютера с помощью 7-Zip LZMA теста

Избранное

Пункт меню | Горячие клавиши | Описание
Добавить папку в избранное как |  | Добавляет папку в избранное

Справка

Пункт меню | Горячие клавиши | Описание
Оглавление... | F1 | Открывает справку 7-Zip
О программе... |  | Открывает диалоговое окно О программе

Разные команды

Горячие клавиши | Описание
Tab | Переключение между панелями
Insert | Выделяет/Снимает выделение текущего пункта
Shift+F10 | Показывает контекстное меню для выбранных пунктов
RightCtrl+0 Alt+0 ... RightCtrl+9 Alt+9 | Открывает закладку папки
Shift+RightCtrl+0 Shift+Alt+0 ... Shift+RightCtrl+9 Shift+Alt+9 | Создает закладку папки
Alt+F1 | Редактирует адрес папки на левой панели
Alt+F2 | Редактирует адрес папки на правой панели
Ctrl+[Grey +] | Корректирует оптимальную ширину столбца для пунктов
Alt+Up | Открывает ту же самую папку в другой панели
Alt+Left, Alt+Right | Открывает текущую папку в другой панели

Горячие клавиши

Клавиша | Нормальный | Ctrl | Alt | Shift
Tab | Переключить панель |  |  |
F1 | Справка |  | Левый путь |
F2 | Переименовать |  | Правый путь |
F3 | Вид | Сортировать по имени |  |
F4 | Редактировать | Сортировать по типу | Выйти | Создать файл
F5 | Копировать | Сортировать по дате |  |
F6 | Переместить | Сортировать по размеру |  |
F7 | Создать папку | Без сортировки |  |
F9 | 1/2 панели |  |  |
F10 | Меню |  |  | Контекстное меню
F12 |  |  | История папок |
0-9 |  | R: Закладка папки | Закладка папки |
A |  | Выделить все |  |
N |  | Создать файл |  |
R |  | Обновить |  |
Z |  | Комментарий |  |
Backspace | Вверх на один уровень |  |  |
Enter | Открыть |  | Свойства | Открыть снаружи
Insert | Выбрать пункт |  |  |
Delete | Удалить пункт |  |  |
Page Down |  | Открыть внутри |  |
Page Up |  | Вверх на один уровень |  |
Up |  |  | Открыть ту же самую папку |
Left |  |  | Открыть текущую папку |
Right |  |  | Открыть текущую папку |
\ | Открыть корень |  |  |
Grey / | Открыть корень |  |  |
Grey * | Выделить все |  |  |
Grey + | Выделить | Корректировать столбцы | Выбор по типу | Выделить все
Grey - | Снять выделение |  | Снять выделение по типу | Убрать выделение


Диалоговое окно Настройки

Вы можете изменить многие из параметров настройки, которые затрагивают 7-Zip Менеджер файлов в диалоговом окне Настройки. Чтобы обратиться к этому диалоговому окну выберите Настройки в меню Сервис.

Диалоговое окно Настройки содержит следующие страницы:

  • Система
  • 7-Zip
  • Папки
  • Редактор
  • Настройки
  • Язык

Страница Система

Позволяет Вам определить поведение 7-Zip в файловой системе.

Ассоциировать 7-Zip с файлами
Перечисляет расширения имени файла и ассоциированные плагины, которые в настоящее время зарегистрированы с 7-Zip. Если расширение имени файла будет отмечено, то 7-Zip будет использоваться для открытия файла с этим расширением. В любом случае Вы можете всегда открывать все архивы 7-Zip-ом щелкнув правой кнопкой мыши через контекстное меню.

Страница 7-Zip

Позволяет Вам определять поведение 7-Zip в оболочке Windows.

Встроить 7-Zip в контекстное меню оболочки
Выберите этот флажок, чтобы добавить команды 7-Zip в контекстное меню оболочки.
Каскадное контекстное меню
Выберите этот флажок, чтобы группировать пункты контекстные меню 7-Zip в одно 7-Zip подменю.
Элементы контекстного меню
Перечисляет дополнительные пункты контекстного меню. Если пункт будет отмечен, то 7-Zip добавит этот пункт в контекстное меню.

Страница Папки

Позволяет Вам устанавливать папки, которые 7-Zip будут использовать для внутренних целей.

Рабочая папка

Раздел Рабочая папка позволяет Вам определять папку, которая будет использоваться для временных файлов архива:

Системная временная папка
7-Zip будет использовать временную папку Windows.
Текущая
7-Zip будет использовать папку, содержащую целевой архив.
Задать
7-Zip будет использовать папку, определенную в следующей строке редактирования.
Использовать только для сменных носителей
Определяет, должен ли 7-Zip использовать определенные параметры настройки папки только для сменных приводов; для других приводов 7-Zip создаст временные архивы в папке, содержащей целевой архив. Если Вы снимите этот флажок, то 7-Zip всегда будет использовать папки, определенные настройками.

7-Zip использует временные файлы архива для всех операций обновления. Так, для скорости, рекомендуется, чтобы Вы выбрали опцию Системная временная папка и выбрали флажок Использовать только для сменных носителей.

Страница Редактор

Позволяет Вам определить параметры настройки для редактора.

Редактор
Определяет путь к редактору, который будет использоваться для команды "Редактировать" (F4).
Diff
Определяет путь к утилите сравнения файлов, которая показывает различия между двумя файлами.

Страница Настройки

Позволяет Вам определить некоторые параметры настройки

Показывать элемент ".."
Показывает пункт .. в списке файлов.
Показывать реальные иконки файлов
Показывает реальные иконки файлов в списке файлов. Если эта опция допускается, обновление списка может происходить медленнее.
Показывать системное меню
Показывает системное контекстное подменю в меню Файл.
Курсор на всю строку
Когда пункт отмечен, пункт и все его подпункты подсвечены.
Показывать разделители
Показывает сетки вокруг пунктов и подпунктов.
Открывать одним щелчком
Если допускается, Менеджер файлов открывает файлы и папки одни щелчком по ним.
Альтернативный режим пометки
Если допускается, Менеджер файлов сохраняет маркер выбора, когда Вы перемещаете курсор.
Использование больших страниц
Если отмечено, 7-Zip будет пробовать использовать большие страницы. Эта особенность позволяет увеличивать скорость сжатия. Это может заставить 7-Zip делать паузу при старте сжатия, из-за распределения больших страниц. Также Диспетчер задач Windows не будет показывать реальное использование памяти программой, если 7-Zip используют большие страницы. Эта особенность работает только на Windows 2003 / XP x64. Также Вы должны иметь права администратора для вашей системы. Рекомендованный размер оперативной памяти: 1 Гб или больше. Чтобы установить эту особенность, Вы должны запустить 7-Zip Менеджер файлов, по крайней мере, один раз, закрыть его и перезагрузить систему.

Страница Язык

Позволяет Вам изменить язык по умолчанию.

Язык
Список доступных языков.


Тестирование производительности

Эта форма позволяет Вам измерить производительность вашего компьютера.

Есть два теста:

  1. Упаковка с методом LZMA
  2. Распаковка с методом LZMA

Тестирование показывает рейтинг в MIPS (миллион команд в секунду). Значение рейтинга вычислено из взвешенной скорости процессора, и оно нормализовано с результатами процессора Intel Core 2 с выключенной опцией многопоточности. Так, если Вы имеете современный процессор Intel или AMD, значения рейтинга должны быть близки к реальной частоте центрального процессора.

Вы можете изменить размер словаря, чтобы увеличить использование памяти. Также Вы можете изменить число потоков.

Столбец Нагрузка показывает процент времени, работы процессора. Она нормализована для загрузки с одним потоком. Например, 180%-ая нагрузка процессора для двух потоков может означать, что среднее использование процессора - приблизительно 90% для каждого потока.

Столбец Рейтинг / Нагр. показывает рейтинг, нормализованный для 100% использования процессора. Этот столбец показывает производительность процессора в один поток. Она должна быть близка к реальной частоте центрального процессора, если у Вас современный центральный процессор.

Общий рейтинг показывает средние числа рейтинга упаковок и распаковок.

Скорость сжатия и рейтинг сильно зависят от времени ожидания памяти (оперативная память).

Скорость распаковки и рейтинг сильно зависит от операций процессора с целыми числами. Например, Intel Pentium 4 имеет большие издержки на ошибочно предсказанные ветвления (которые являются следствием длинного конвейера), и довольно медленные операции умножения и сдвига. Таким образом, Pentium 4 имеет довольно низкий рейтинг распаковки.

Также программа проверяет возможные ошибки. Если программа показывает небольшое количество сообщения об ошибках, в большинстве случаев это означает, что ваша оперативная память неисправна. Если так, не используйте 7-Zip для сжатия данных, так как такие ошибки могут привести к потере данных.


Диалог О программе

Диалоговое окно О программе

Диалоговое окно О программе показывает информацию о 7-Zip. Это диалоговое окно доступно в меню Справка.

  • Нажмите кнопку www.7-zip.org для открытия Домашней страницы 7-Zip.


Плагины

7-Zip Менеджер файлов может использовать внутренние и внешние плагины.

В настоящее время 7-Zip использует следующие плагины:

7-Zip
Плагин для управления архивами.


7-Zip плагин

7-Zip плагин для управления архивами. Он заставляет все файлы архивов быть похожими на обычные папки в менеджере файлов.

Большинство операций со сжатыми файлами может быть вызвано, используя щелчок правой кнопкой мыши на файлах в Менеджере файлов (или в Проводнике Windows) и выборе соответствующей команды из меню.

Использование 7-Zip

Открытие архива

Есть два способа открыть файл архива:

  • Если Вы имеете файл, тип которого ассоциированный с 7-Zip, то Вы можете открыть файл в 7-Zip дважды щелкнув файл или щелкнув правой кнопкой мыши и выбирав команду Открыть.
  • Вы можете щелкнуть правой кнопкой мыши по файлу архива, указать на 7-Zip, и затем щелкнуть пункт команды Открыть.
Извлечение архива

Есть два способа извлечь файлы из архива:

  • Чтобы извлечь все файлы из архива щелкните правой кнопкой мыши по файлу архива, укажите на 7-Zip, и затем щелкните пункт команды Извлечь файлы....
  • Чтобы извлечь определенные файлы из архива откройте архив в 7-Zip, выберите пункты для извлечения и выполните команду Копировать в....

Появится диалог Извлечения.

Тестирование архива

Чтобы проверить архив, щелкните правой кнопкой мыши по файлу архива, укажите на 7-Zip, и затем щелкните пункт команды Тестировать.

Создание и обновление файлов в архиве

Для того, чтобы создать или обновить файл архива, щелкните правой кнопкой мыши по файлу(ам) или папке(ам), которую Вы хотите сжать, укажите на 7-Zip, и затем щелкните пункт команды Добавить к архиву.... Появится диалог Добавить к архиву.


Диалоговое окно Добавить к архиву

Позволяет Вам определять опции для создания или обновления архива.

Как вызывать это диалоговое окно

  1. В Проводнике Windows или в 7-Zip, щелкните правой кнопкой мыши по файлу(ам) или папке(ам), которые Вы хотите сжать.
  2. Укажите на 7-Zip, и затем щелкните пункт команды Добавить в архив...

Параметры

Архив
Обеспечивает Вам место для ввода имени архива адресата. Вы можете щелкнуть кнопкой "...", чтобы отобразить диалоговое окно "Открыть", которое Вы можете использовать, чтобы определить местонахождение архива.
Формат архива
Определяет формат созданного архива. Некоторые форматы (gzip и bzip2) не поддерживают сжатие больше одного файла в архив.
Уровень сжатия

Определяет уровень сжатия. Есть 6 уровней сжатия:

Значение | Смысл
Без сжатия | Файлы будут скопированы в архив без сжатия.
Скоростной | Самое быстрое сжатие.
Быстрый | Быстрое сжатие.
Нормальный | Сжатие со сбалансированными параметрами настройки.
Максимальный | Может дать более высокую степень сжатия чем Нормальный уровень. Но это может быть медленнее, и может потребовать большего количества памяти.
Ультра | Может дать более высокую степень сжатия чем Максимальный уровень. Но это может быть медленнее, и может потребовать большего количества памяти.
Метод сжатия

Определяет метод сжатия. Каждый формат архива может иметь свои собственные методы сжатия:

Метод | Описание
LZMA | Метод сжатия по умолчанию формата 7z. Он обеспечивает высокую степень сжатия и очень быструю распаковку.
LZMA2 | Метод сжатия на основе LZMA. Он обеспечивает лучшую поддержку многопоточности чем LZMA. Но в некоторых случаях степень сжатия может быть хуже. Для лучшей степени сжатия с LZMA2 используется 1 или 2 потока процессора. Если Вы используете LZMA2 с более чем 2-мя потоками, 7-zip разделяет данные на куски, и сжимает эти куски независимо (2 потока в каждый кусок).
PPMd | Алгоритм Дмитрия Шкарина PPMdH с небольшими изменениями. Обычно он обеспечивает высокую степень сжатия и высокую скорость для текстовых файлов.
BZip2 | Стандартный метод сжатия, основанный на BWT алгоритме. Обычно он обеспечивает высокую скорость и довольно хорошую степень сжатия для текстовых файлов.
Deflate | Стандартный метод сжатия форматов ZIP и GZIP. Степень сжатия не слишком высока. Но он обеспечивает довольно быстрое сжатие и распаковку. Deflate метод поддерживает словарь только на 32 кб.
Deflate64 | Измененная версия Deflate алгоритма с большим словарем (64 кб).

Предполагаемая производительность 7-Zip и требуемые объемы и конфигурации памяти для AMD Athlon 64 X2 3800+:

Метод | Уровень | Размер словаря | Скорость сжатия | Скорость распаковки | Память для сжатия | Память для распаковки
LZMA | скоростной | 64 кб | 4.5 Мб/с | 15 Мб/с | 3 Мб | 3 Мб
быстрый | 1 Мб | 3 Мб/с | 10 Мб | 3 Мб
нормальный | 16 Мб | 2 Мб/с | 186 Мб | 18 Мб
максимальный | 32 Мб | 1.8 Мб/с | 376 Мб | 34 Мб
ультра | 64 Мб | 1.6 Мб/с | 709 Мб | 66 Мб
PPMD | быстрый | 4 Мб | 1.4 Мб/с | 6 Мб
нормальный | 24Мб | 1.2 Мб/с | 26 Мб
максимальный | 64 Мб | 1.0 Мб/с | 66 Мб
ультра | 192 Мб | 0.9 Мб/с | 194 Мб
Deflate | быстрый | 32 кб | 15 Мб/с | 40 Мб/с | 3 Мб | 2 Мб
нормальный | 3.5 Мб/с
максимальный | 1.5 Мб/с | 4Мб
ультра | 0.4 Мб/с
BZip2 | нормальный | 900 кб | 3 Мб/с | 16 Мб/с | 20 Мб | 7 Мб
максимальный | 1.2 Мб/с
ультра | 0.4 Мб/с
Размер словаря

Определяет размер словаря для метода сжатия.

Обычно больший размер словаря дает выше степень сжатия. Но сжатие может быть медленнее, и это может потребовать большее количество памяти.

Память (оперативная память), используемая для LZMA сжатия - приблизительно в 11 раз больше чем размер словаря. Использование памяти для LZMA распаковки - близко к значению размера словаря. Использование памяти для PPMd сжатия и распаковки почти равно размеру словаря.

Размер слова

Определяет длину слов, которые будут использоваться, чтобы найти идентичные последовательности байтов для сжатия.

Обычно для LZMA и Deflate большой размер слова, дает немного лучшую степень сжатия и более медленный процесс сжатия. Параметр размер Слова может значительно увеличить степень сжатия для файлов, которые содержат длинные идентичные последовательности байтов. Для PPMd, размер Слова сильно влияет и на степень сжатия, и на скорость сжатия/распаковки.

Размер блока

Определяет размер solid блока. Вы можете также отключить solid режим. В solid режиме все файлы будут сжаты как непрерывные блоки данных. Обычно сжатие в solid архив улучшает степень сжатия. Вы можете использовать эту опцию только для 7z архивов. Обновление solid .7z архивов может быть медленным, так как, может потребоваться некоторое пересжатие.

Число потоков
Определяет число потоков для сжатия. Большое число потоков может увеличить скорость сжатия на многопроцессорных системах. Иногда это может увеличить скорость даже на одноядерном процессоре.
Разбить на тома размером (в байтах)
    {Size}[b | k | m | g]

Определяет размеры томов в байтах, килобайтах (1 килобайт = 1024 байта), Мегабайтах (1 Мегабайт = 1024 килобайта) или Гигабайтах (1 Гигабайт = 1024 Мегабайта). Если Вы определили только {Size}, 7-zip обработает это как байты. Можно определить несколько значений. Пример:

    10k 15k 2m

Первый том будет 10 кб, второй будет 15 кб, а все остальные будут 2 Мб.

Параметры

Позволяет Вам определять параметры для сжатия. Для подробностей см. описание ключа -m (Method). Опустите префикс -m (как в ключе -m), используя это диалоговое окно.

Примеры

      0=PPMd

использование PPMd метода для сжатия файлов.

      0=bcj2 1=lzma:d23 2=lzma 3=lzma b0:1 b0s1:2 b0s2:3

использование BCJ2 фильтра (для x86 исполнительных программ) и LZMA.

Режим изменения

Определяет режим обновления:

Значение | Смысл
Добавить и заменить | Добавляет все указанные файлы в архив.
Обновить и добавить | Обновляет старые файлы в архиве и добавляет новые файлы в архив.
Обновить | Обновляет определенные файлы в архиве, которые старее чем выбранные файлы на диске.
Синхронизировать | Заменяет определенные файлы, только если добавляемые файлы более новые. Всегда добавляет те файлы, которые отсутствуют в архиве. Удаляет из архива те файлы, которые отсутствуют на диске.
Опции

Определяет опции сжатия:

Опция | Смысл
Создать SFX архив | Создает само-извлекающийся архив. Вы можете использовать эту опцию только для 7z архивов. Обратитесь к описанию ключа -sfx (Create SFX archive) для подробностей о SFX модулях.
Сжимать открытые для записи файлы | Сжимает файлы, открытые для записи другим приложением.
Шифрование

Определяет пароль для опции шифрования.

Введите пароль
Определите пароль здесь
Повторите пароль
Повторите пароль здесь для сравнения
Показывать пароль
Показать пароль
Метод шифрования
Определяет метод шифрования. Для 7z формата это может быть только AES-256. Для ZIP формата Вы можете выбрать ZipCrypto или AES-256. Используйте ZipCrypto, если Вы хотите получить архив, совместимый с большинством ZIP архиваторов. AES-256 обеспечивает более сильное шифрование, но сейчас AES-256 поддержан только 7-Zip-ом, WinZip-ом и некоторыми другими ZIP архиваторами.
Шифровать имена файлов
Допускает или отключает шифрование заголовка архива, включая шифрование имен файлов


Диалоговое окно Извлечения

Диалоговое окно Извлечь

Позволяет Вам определять опции для извлечения файлов от архива.

Как запустить это диалоговое окно

Есть два способа запустить этот диалог

  • Извлечь все файлы из архива:
    1. В Проводнике Windows или в 7-Zip, щелкните правой кнопкой мыши по файлу архива.
    2. Указать на 7-Zip, и затем щелкнуть Извлечь файлы....
  • Извлечь определенные файлы из архива, открытого в окне просмотра:
    1. Открыть архив с 7-Zip.
    2. Выбрать пункты для извлечения.
    3. Щелкнуть правой кнопкой мыши по пунктам и затем щелкните Копировать в....

Параметры

Распаковать в
Обеспечивает Вам место для ввода имени папки вывода. Вы можете щелкнуть кнопкой "...", чтобы отобразить диалоговое окно "Выбор папки", которое Вы можете использовать для определения местонахождение папки вывода.
Пути

Определяет режим извлечения:

Значение | Смысл
Полные пути | Извлекает файлы с полными именами пути.
Без путей | Извлекает файлы без путей папки.
Перезапись

Определяет режим замены для файлов, которые уже представлены на диске:

Значение | Смысл
С подтверждением | Спрашивает перед перезаписью существующих файлов.
Без подтверждения | Перезаписывает существующие файлы без подсказки.
Пропускать | Пропускает извлечение существующих файлов.
Переименовать автом. | Переименовывает извлекаемые файлы, если файл с таким именем уже существует. Например, файл document.txt будет переименован в document_1.txt.
Переим. автом. существ. | Переименовывает существующих файлы, если файл с таким именем уже существует. Например, файл document.txt будет переименован в document_1.txt.
Файлы

Определяет файлы для извлечения:

Значение | Смысл
Выбранные файлы | Извлекает только файлы, которые выбраны в основном окно.
Все файлы | Извлечь все файлы.
Пароль

Определяет пароль для зашифрованных архивов.


Руководство пользователя версии Командной строки

7z.exe - версия командной строки 7-Zip. 7z.exe использует 7z.dll из 7-Zip пакета. 7z.dll также используются Менежером файлов 7-Zip.

7za.exe (a = alone (один)) - автономная версия 7-Zip. 7za.exe поддерживает только 7z, lzma, cab, zip, gzip, bzip2, Z и tar форматы. 7za.exe не использует внешние модули.

  • Синтаксис Командной строки
  • Коды завершения
  • Команды
  • Ключи


Синтаксис Командной строки

7z <command> [<switch>...] <base_archive_name> [<arguments>...]

<arguments> ::= <switch> | <wildcard> | <filename> | <list_file>
<switch>::= <switch_symbol><switch_characters>[<option>]
<switch_symbol> ::= '/' | '-'
<list_file> ::= @{filename}

Выражения в квадратных скобках (между '[' и ']') являются дополнительными.

Выражения в фигурных скобках ('{' и '}') означают, что вместо этого Выражения (включая фигурные скобки) пользователь должен заменить некоторой строкой.

Выражения (Expression)

expression1 | expression2 | ... | expressionN

средства, любое (но только одно) из этих выражений должно быть определено.

Команды (command) и ключи (switch) могут быть введены заглавными или строчными буквами.

Команда - первый параметр, не ключ, в командной строке.

"base_archive_name" должен быть первым именем файла на командной строке после команды.

Ключи и другие имена файлов могут быть в любом порядке.

Подстановочные знаки или имена файла с пробелами должны быть заключены в кавычки:

    "Dir\Program files\*"
    Dir\"Program files"\*

Опции ключей могут быть объединены, чтобы сократить длину командной строки. Однако некоторые опции ключа берут дополнительные параметры строки и поэтому, должны быть последней опцией в объединенной строке маркера параметра, потому что, 7-Zip воспринимает остальная часть вводов маркера параметра как дополнительный параметр.

7-Zip использует wild имя, соответствующее подобному в Windows 95:

  • '*' означает последовательность произвольных символов.
  • '?' означает любой символ.

7-Zip не использует системный синтаксический анализатор подстановочных знаков, и 7-Zip не следует тому архаичному правилу, по которому *.* означает любой файл. 7-Zip обрабатывает *.* как соответствие имени любого файла, который имеет расширение. Чтобы обрабатывать все файлы, Вы должны использовать подстановочные знаки *.

Примеры:

*.txt | означает все файлы с расширением ".txt"
?a* | означает все файлы со вторым символом "a"
*1* | означает все имена, который содержит символ "1"
*.*.* | означает все имена, которые содержат по крайней мере два символа "."

По умолчанию подстановочные знаки "*" будут использоваться, если не будет никакого имени файла/подстановочных знаков в командной строке.

Слеш ('\') в конце пути означает каталог. Без слеша ('\') в конце пути, путь может относиться и к файлу и к каталогу.

Файл-список

Вы можете поставлять одно или более имен файлов или подстановочные знаки для специальных файл-списков (файлы, содержащие списки файлов). Имена файлов в таком файл-списке должны быть разделены символом(ами) перевода строки.

Для файл-списка 7-Zip использует, по умолчанию кодировку UTF-8.

Множественные файл-списки поддержаны.

Например, если файл "listfile.txt" содержит следующее:

    My programs\*.cpp
    Src\*.cpp

тогда команда

    7z a -tzip archive.zip @listfile.txt

добавляет к архиву "archive.zip" все "*.cpp" файлы из каталогов "My programs" и "Src".

Короткие и длинные имена файлов

7-Zip поддерживает короткие имена файлов (как FILENA~1.TXT) в некоторых случаях. Однако, строго рекомендуют использовать только реальные (длинные) имена файлов.


Коды завершения 7-Zip

7-Zip возвращает следующие коды завершения:

Код | Значение
0 | Нет ошибок
1 | Предупреждение (Не фатальная ошибка(и)). Например, один или более файлов были блокированы другим приложением, таким образом, они не были сжаты.
2 | Фатальная ошибка
7 | Ошибка командной строки
8 | Недостаточно памяти для операции
255 | Пользователь остановил процесс


Команды Командной строки

Команда - первый параметр, не ключ, в командной строке.

Названия команд не чувствительны к регистру.

См. также синтаксис Командной строки для подробностей об использовании командной строки.

Справочник команд

Команда | Описание
a | Add
b | Benchmark
d | Delete
e | Extract
l | List
t | Test
u | Update
x | eXtract with full paths


a (Добавить) команда

a (Add) команда

Добавляет файлы в архив.

Примеры

7z a archive1.zip subdir\

добавляет все файлы и подкаталоги из каталога subdir в архив archive1.zip. Имена файлов в архиве будут содержать префикс subdir\.

7z a archive2.zip .\subdir\*

добавляет все файлы и подкаталоги из каталога subdir в архив archive2.zip. Имена файлов в архиве не будут содержать префикс subdir\.

cd /D c:\dir1\
7z a c:\archive3.zip dir2\dir3\
Имена файлов в архиве c:\archive3.zip будут содержать префикс dir2\dir3\, но они не будут содержать префикс c:\dir1\.
7z a Files.7z *.txt -r

добавляет все *.txt файлы из текущего каталога его подкаталогов в архив Files.7z.

Примечание

7-Zip не использует системный синтаксический анализатор подстановочных знаков, и 7-Zip не следует тому архаичному правилу, по которому *.* означает любой файл. 7-Zip обрабатывает *.* как соответствие имени любого файла, который имеет расширение. Чтобы обрабатывать все файлы, Вы должны использовать подстановочные знаки *.

Ключи, которые могут использоваться с этой командой

-i (Include)
-m (Method)
-p (Set Password)
-r (Recurse)
-sfx (create SFX)
-si (use StdIn)
-so (use StdOut)
-ssw (Compress shared files)
-t (Type of archive)
-u (Update)
-v (Volumes)
-w (Working Dir)
-x (Exclude)

См. также

Команды: d (Delete), u (Update)

Ключи: -u (Update)


b (Тестирование производительности) команда

b (Benchmark) команда

Оценивает скорость процессора и проверяет оперативную память на ошибки.

Синтаксис

b [number_of_iterations] [-mmt{N}] [-md{N}] [-mm={Method}]

Есть два теста:

  1. Сжатие с методом LZMA
  2. Распаковка с методом LZMA

Тестирование показывает рейтинг в MIPS (миллион команд в секунду). Значение рейтинга вычислено из взвешенной скорости процессора, и оно нормализовано с результатами процессора Intel Core 2 с выключенной опцией многопоточности. Так, если Вы имеете Intel Core 2 Duo, значения рейтинга должны быть близко к реальной частоте центрального процессора.

Вы можете увеличить размер словаря, чтобы увеличить использование памяти ключом -md{N}. Также Вы можете изменить число потоков ключом -mmt{N}.

Столбец Dict показывает размер словаря. Например, 21 означает 2^21 = 2 Мб.

Столбец Usage показывает процент времени, работы процессора. Оно нормализовано для загрузки с одним потоком. Например, 180%-ая нагрузка процессора для двух потоков может означать, что среднее использование процессора - приблизительно 90% для каждого потока.

Столбец R / U показывает рейтинг, нормализованный для 100% использования процессора. Этот столбец показывает усредненную работу процессора в один поток.

Avr показывает среднее значение для различных размеров словаря.

Tot показывает среднее значение рейтингов сжатий и распаковок.

Скорость сжатия и рейтинг сильно зависят от времени ожидания памяти (оперативная память).

Скорость распаковки и рейтинг сильно зависят от целочисленной части процессора. Например, Intel Pentium 4 имеет большой переход misprediction penalty (который является эффектом длинного конвейера), и довольно медленные операции умножения и сдвига. Таким образом, Pentium 4 имеет довольно низкий рейтинг распаковки.

Вы можете запустить тест вычисления CRC, определяя ключ -mm=crc. Этот тест показывает скорость вычисления CRC в Мб/сек. Первый столбец показывает размер блока. Следующий столбец показывает скорости вычисления CRC для одного потока. Другие столбцы - результаты для многопоточного вычисления CRC.

Примеры

7z b
запуск тестирования.
7z b -mmt1 -md26
запуск тестирования с одним потоком и словарем на 64 Мб.
7z b 30

запуск тестирования с настройками по умолчанию для 30 итераций.


d (Удалить) команда

d (Delete) команда

Удаляет файлы из архива.

Пример

7z d archive.zip *.bak -r

удаляет *.bak файлы из архива archive.zip.

Примечание

7-Zip не использует системный синтаксический анализатор подстановочных знаков, и 7-Zip не следует тому архаичному правилу, по которому *.* означает любой файл. 7-Zip обрабатывает *.* как соответствие имени любого файла, который имеет расширение. Чтобы обрабатывать все файлы, Вы должны использовать подстановочные знаки *.

Ключи, которые могут использоваться с этой командой

-i (Include)
-m (Method)
-p (Set Password)
-r (Recurse)
-u (Update)
-w (Working Dir)
-x (Exclude)

См. также

Команды: a (Add), u (Update)

Ключи: -u (Update)


e (Извлечь) команда

e (Extract) команда

Извлекает файлы из архива в текущий каталог или в каталог вывода. Каталог вывода может быть определен ключом -o (Set Output Directory).

Эта команда копирует все извлеченные файлы в один каталог. Если Вы хотите извлечь файлы с полными путями, Вы должны использовать команду x (Extract with full paths).

7-Zip выдаст запрос пользователю перед перезаписью существующих файлов, если пользователь не установит ключ -y (Assume Yes on all queries). Если пользователь ответит нет, то 7-Zip выдаст запрос, должен ли файл быть извлечен под новым именем. Далее ответ нет - пропускает файл, а да запросит новое имя файла.

7-Zip принимает следующие ответы:

Ответ | Сокращенный | Действие
Yes | y |
No | n |
Always | a | Принять ДА для ВСЕХ последующих запросов того же самого класса
Skip | s | Принять НЕТ для ВСЕХ последующих запросов того же самого класса
Quit | q | Выйти из программы

Сокращенные ответы допустимы.

Примеры

7z e archive.zip

извлекает все файлы из архива archive.zip в текущий каталог.

7z e archive.zip -oc:\soft *.cpp -r

извлекает все *.cpp файлы из архива archive.zip в папку c:\soft.

Примечание

7-Zip не использует системный синтаксический анализатор подстановочных знаков, и 7-Zip не следует тому архаичному правилу, по которому *.* означает любой файл. 7-Zip обрабатывает *.* как соответствие имени любого файла, который имеет расширение. Чтобы обрабатывать все файлы, Вы должны использовать подстановочные знаки *.

Ключи, которые могут использоваться с этой командой

-ai (Include archives)
-an (Disable parsing of archive_name)
-ao (Overwrite mode)
-ax (Exclude archives)
-i (Include)
-o (Set Output Directory)
-p (Set Password)
-r (Recurse)
-so (use StdOut)
-t (Type of archive)
-x (Exclude)
-y (Assume Yes on all queries)

См. также

Команды: x (Extract with full paths)


l (Список содержания архива) команда

l (List contents of archive) команда

Список содержания архива.

Пример

7z l archive.zip

перечислит все файлы в архиве archive.zip.

Примечание

7-Zip не использует системный синтаксический анализатор подстановочных знаков, и 7-Zip не следует тому архаичному правилу, по которому *.* означает любой файл. 7-Zip обрабатывает *.* как соответствие имени любого файла, который имеет расширение. Чтобы обрабатывать все файлы, Вы должны использовать подстановочные знаки *.

Ключи, которые могут использоваться с этой командой

-ai (Include archives)
-an (Disable parsing of archive_name)
-ax (Exclude archives)
-i (Include)
-slt (Show technical information)
-p (Set Password)
-r (Recurse)
-t (Type of archive)
-x (Exclude)


t (Тест файлов в архиве) команда

t (Test integrity of archive) команда

Тестирует файлы в архиве.

Пример

7z t archive.zip *.doc -r

тестирует *.doc файлы в архиве archive.zip.

Примечание

7-Zip не использует системный синтаксический анализатор подстановочных знаков, и 7-Zip не следует тому архаичному правилу, по которому *.* означает любой файл. 7-Zip обрабатывает *.* как соответствие имени любого файла, который имеет расширение. Чтобы обрабатывать все файлы, Вы должны использовать подстановочные знаки *.

Ключи, которые могут использоваться с этой командой

-ai (Include archives)
-an (Disable parsing of archive_name)
-ax (Exclude archives)
-i (Include)
-p (Set Password)
-r (Recurse)
-x (Exclude)


u (Обновить) команда

u (Update) команда

Обновляет старые файлы в архиве и добавляет файлы, которых нет в архив.

Примечание: обновление solid .7z архивов может быть медленным, так как, может потребоваться некоторое пересжатие.

Пример

7z u archive.zip *.doc

обновляет *.doc файлы в архиве archive.zip.

Примечание

7-Zip не использует системный синтаксический анализатор подстановочных знаков, и 7-Zip не следует тому архаичному правилу, по которому *.* означает любой файл. 7-Zip обрабатывает *.* как соответствие имени любого файла, который имеет расширение. Чтобы обрабатывать все файлы, Вы должны использовать подстановочные знаки *.

Ключи, которые могут использоваться с этой командой

-i (Include)
-m (Method)
-p (Set Password)
-r (Recurse)
-sfx (create SFX)
-si (use StdIn)
-so (use StdOut)
-ssw (Compress shared files)
-t (Type of archive)
-u (Update)
-w (Working Dir)
-x (Exclude)

См. также

Команды: a (Add), d (Delete),

Ключи: -u (Update)


x (Извлечь с полными путями) команда

x (Extract with full paths) команда

Извлекает файлы из архива, с их полными путями, в текущий каталог или в каталог вывода, если определен.

Для подробностей см. описание команды e (Extract).

Примеры

7z x archive.zip

извлекает все файлы из архива archive.zip в текущий каталог.

7z x archive.zip -oc:\soft *.cpp -r

извлекает все *.cpp файлы из архива archive.zip в папку c:\soft.

Примечание

7-Zip не использует системный синтаксический анализатор подстановочных знаков, и 7-Zip не следует тому архаичному правилу, по которому *.* означает любой файл. 7-Zip обрабатывает *.* как соответствие имени любого файла, который имеет расширение. Чтобы обрабатывать все файлы, Вы должны использовать подстановочные знаки *.

Ключи, которые могут использоваться с этой командой

-ai (Include archives)
-an (Disable parsing of archive_name)
-ao (Overwrite mode)
-ax (Exclude archives)
-i (Include)
-o (Set Output Directory)
-p (Set Password)
-r (Recurse)
-so (use StdOut)
-t (Type of archive)
-x (Exclude)
-y (Assume Yes on all queries)

См. также

Команды: e (Extract)


Ключи Командной строки

Синтаксис

<switch>::= <switch_symbol><switch_characters>[<option>]
<switch_symbol> ::= '/' | '-'

В командной строке, ключ состоит из спецификатора ключа, черточки (-) или косой черты (/), сопровождаемой именем ключа. Имена ключей не могут быть сокращены.

Некоторые ключи берут параметр, определенный после имени ключа. Никакие пробелы или табуляции не допускаются в пределах спецификации ключа. Имена ключей не чувствительны к регистру, но параметры могут быть чувствительными к регистру.

Ключ может использоваться в любом месте в командной строке.

См. также Синтаксис Командной строки для подробностей об использовании командной строки.

Справочник ключей

Ключ | Описание
-- | Stop switches parsing
-ai | Include archive filenames
-an | Disable parsing of archive_name
-ao | Overwrite mode
-ax | Exclude archive filenames
-i | Include filenames
-m | Set Compression Method
-o | Set Output directory
-p | Set Password
-r | Recurse subdirectories
-scc | Set charset for for console input/output
-scs | Set charset for list files
-seml | Send archive by email
-slp | Set Large Pages mode
-slt | Show technical information
-sfx | Create SFX archive
-sii | Read data from StdIn
-so | Write data to StdOut
-ssc | Set Sensitive Case mode
-ssw | Compress files open for writing
-t | Type of archive
-u | Update options
-v | Create Volumes
-w | Set Working directory
-x | Exclude filenames
-y | Assume Yes on all queries


-- (Остановить разбор ключей) ключ

-- (Stop switches parsing) ключ

Отключает синтаксический анализ ключей после "--" в командной строке. Это должно позволить 7-Zip-у использовать имена файлов, которые начинаются с "-".

Синтаксис

--

Пример

7z t -- -ArchiveName.7z

тестирует архив -ArchiveName.7z.


-ai (Включить в архив имена файлов) ключ

-ai (Include archive filenames) ключ

Определяет дополнительно включаемые имена файлов архива и подстановочные знаки.

Множественные включающие ключи, поддержаны.

Синтаксис

-ai[<recurse_type>]<file_ref>

<recurse_type> ::= r[- | 0]
<file_ref> ::= @{listfile} | !{wildcard}

Параметры

<recurse_type>

Определяет, как подстановочные знаки и имена файла, определенные в этом ключе должны использоваться. Если эта опция не будет назначена, то рекурсия использоваться не будет. Для подробностей см. описание ключа -r (Recurse).

<recurse_type> ::= r[- | 0]
<file_ref>

Определяет имена файлов и подстановочные знаки или файл-список, который определяет обрабатываемые файлы.

<file_ref> ::= @{listfile} | !{wildcard}
Опция | Описание
{listfile} | Определяет имя файл-списка. См. описание Файл-список.
{wildcard} | Определяет подстановочные знаки или имя файла.

Пример

7z t -an -air!*.7z

тестирует *.7z архивы в текущем каталоге и все его подкаталоги.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), e (Extract), l (List), t (Test), u (Update), x (Extract with full paths)

См. также

Ключи: -ax (Exclude archives) -an (Disable parsing of archive_name)


-an (Отключить синтаксический анализ archive_name) ключ

-an (Disable parsing of archive_name) ключ

Отключает синтаксический анализ поля archive_name в командной строке. Этот ключ должен использоваться с ключом -ai (Include archives). Если Вы используете файл-список для ваших архивов, Вы определяете его с ключом -ai, таким образом, Вы должны отключить синтаксический анализ поля archive_name командной строки.

Синтаксис

-an

Пример

7z t -an -ai!*.7z -ax!a*.7z

тестирует все *.7z архивы, кроме a*.7z архивов.

Команды, которые могут использоваться с этим ключом

e (Extract), l (List), t (Test), x (Extract with full paths)

См. также

Ключи: -ai (Include archives) -ax (Exclude archives)


-ao (Метод перезаписи) ключ

-ao (Overwrite mode) ключ

Определяет режим замены в ходе извлечения для замены файлов, уже имеющихся на диске.

Синтаксис

-ao[a | s | t | u ]

Ключ | Описание
-aoa | Перезаписывает все существующие файлы без подсказки.
-aos | Пропустит извлечение существующих файлов.
-aou | Автоматически переименует извлекаемый файл (например, name.txt будет переименован в name_1.txt).
-aot | Автоматически переименует существующий файл (например, name.txt будет переименован в name_1.txt).

Пример

7z x test.zip -aoa

извлекает все файлы из архива test.zip и перезаписывает, существующее файлы без всякой подсказки.

Команды, которые могут использоваться с этим ключом

e (Extract), x (Extract with full paths)

См. также

Ключи: -y (assume Yes on all queries),


-ax (Исключить из архива имена файлов) ключ

-ax (Exclude archive filenames) ключ

Определяет архивы, которые будут исключены из операции.

Множественные исключающие ключи архива, поддержаны.

Синтаксис

-ax[<recurse_type>]<file_ref>

<recurse_type> ::= r[- | 0]
<file_ref> ::= @{listfile} | !{wildcard}

См. описание ключа -xi (Include archive filenames) для информации о параметрах опции.

Пример

7z t -an -ai!*.7z -ax!a*.7z

тестирует все *.7z архивы, кроме a*.7z архивов.

Команды, которые могут использоваться с этим ключом

e (Extract), l (List), t (Test), x (Extract with full paths)

См. также

Ключи: -ai (Include archives) -an (Disable parsing of archive_name)


-i (Включить имена файлов) ключ

-i (Include filenames) ключ

Определяет дополнительно включаемые имена файлов и подстановочные знаки.

Множественные включающие ключи, поддержаны.

Синтаксис

-i[<recurse_type>]<file_ref>

<recurse_type> ::= r[- | 0]
<file_ref> ::= @{listfile} | !{wildcard}

Параметры

<recurse_type>

Определяет, как подстановочные знаки и имена файлов, определенные в этом ключе должны использоваться. Если эта опция не будет назначена, тогда, будет использоваться назначенное глобальное значение, ключа -r (Recurse). Для подробностей см. описание ключа -r (Recurse) .

<recurse_type> ::= r[- | 0]
<file_ref>

Определяет имена файлов и подстановочные знаки или файл-список, для файлов, которые будут обработаны.

<file_ref> ::= @{listfile} | !{wildcard}
Опция | Описание
{listfile} | Определяет имя файл-списка. См. описание Файл-список.
{wildcard} | Определяет подстановочные знаки или имя файла.

Пример

7z a -tzip src.zip *.txt -ir!DIR1\*.cpp

добавляет в архив src.zip все *.txt файлы из текущего каталога и все *.cpp файлы из каталога DIR1 и из всех его подкаталогов.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), e (Extract), l (List), t (Test), u (Update), x (Extract with full paths)

См. также

Ключи: -r (Recurse), -x (Exclude)


-m (Установить метод сжатия) ключ

-m (Set compression Method) ключ

Определяет метод сжатия.

Синтаксис

-m<method_parameters>

Формат для этого ключа зависит от типа архива.

  • Zip
  • GZip
  • BZip2
  • 7z
  • XZ

Zip

Параметр | Значение по умолчанию | Описание
x=[0 | 1 | 3 | 5 | 7 | 9 ] | 5 | Устанавливает уровень сжатия.
m={MethodID} | Deflate | Устанавливает метод: Copy, Deflate, Deflate64, BZip2, LZMA, PPMd.
fb={NumFastBytes} | 32 | Устанавливает число быстрых байтов для Deflate кодера.
pass={NumPasses} | 1 | Устанавливает число проходов для Deflate кодера.
d={Size}[b|k|m] | 900000 | Устанавливает размер словаря для BZip2
mem={Size}[b|k|m] | 24 | Устанавливает размер памяти, используемой для PPMd
o={Size} | 8 | Устанавливает порядок модели для PPMd.
mt=[off | on | {N}] | on | Устанавливает режим многопоточности.
em={EncryptionMethodID} | ZipCrypto | Устанавливает метод шифрования: ZipCrypto, AES128, AES192, AES256
tc=[off | on] | on | Сохраняет NTFS "штамп времени" (timestamps) создания файла.
cl=[off | on] | off | 7-Zip всегда использует локальную кодовую страницу для имен файлов.
cu=[off | on] | off | 7-Zip использует UTF-8 для имен файлов, которые содержат не-ASCII символы.

По умолчанию (если cl и cu ключи не определены), 7-Zip использует UTF-8 кодирование только для имен файлов, которые содержат символы, неподдерживаемые локальной кодовой страницей.

x=[0 | 1 | 3 | 5 | 7 | 9 ]

Устанавливает уровень сжатия. x=0 означает режим Copy (никакого сжатия).

Установки Deflate / Deflate64:

Уровень | Число быстрых байтов | Число проходов | Описание
1 | 32 | 1 | Самый быстрый
3 | Быстрый
5 | Нормальный
7 | 64 | 3 | Максимальный
9 | 128 | 10 | Ультра

x=1 и x=3 с Deflate методом устанавливают быстрый режим для сжатия.

Установки BZip2:

Уровень | Словарь | Число проходов | Описание
1 | 100000 | 1 | Самый быстрый
3 | 500000 | Быстрый
5 | 900000 | Нормальный
7 | 2 | Максимальный
9 | 7 | Ультра
fb={NumFastBytes}

Установка числа быстрых байтов для Deflate/Deflate64 кодера. Оно может быть в диапазоне от 3 до 258 (257 для Deflate64). Обычно большее число дает немного лучшую степень сжатия и более медленный процесс сжатия. Большие числа параметра быстрых байтов может значительно увеличить степень сжатия в случае, когда файлы содержат длинные идентичные последовательности байтов.

pass={NumPasses}

Установка числа проходов для Deflate кодера. Оно может быть в диапазоне от 1 до 15 для Deflate и от 1 до 10 для BZip2. Обычно большее число дает немного лучшую степень сжатия и более медленный процесс сжатия.

d={Size}[b|k|m]

Установка размера словаря для BZip2. Вы должны определить размер в байтах, килобайтах, или Мегабайтах. Максимальное значение для размера словаря - 900000 байт. Если Вы не определите никакого символа из [b|k|m], то размер словаря будет вычислен как Размер_словаря = 2^Size байт.

mem={Size}[b|k|m]

Устанавливает размер памяти, используемой для PPMd. Вы должны определить размер в байтах, килобайтах, или Мегабайтах. Максимальное значение составляет 256 Мбайт = 2^28 байтов. Значение по умолчанию 24 (16 МБ). Если Вы не определите никакого символа из [b|k|m], то размер памяти будет вычислен как (2^Size) байт. PPMd использует одинаковый размер памяти для сжатия и распаковки.

o={Size}

Устанавливает порядок модели для PPMd. Размер Размер должен быть в диапазоне [2,16]. Значение по умолчанию 8.

mt=[off | on | {N}]

Установка режима многопоточности. Если Вы имеете многопроцессорную или многоядерную систему, Вы можете получить увеличение скорости, с этим ключом. Эта опция эффективна только для сжатия (с любым методом) и распаковки с BZip2 потоками. Каждый поток в режиме многопоточности использует 32 Мб оперативной памяти для буферизации. Если Вы определяете {N}, 7-Zip пробуют использовать N потоков.

GZip

GZip использует те же самые параметры как Zip, но GZip сжимает только с методом Deflate. Таким образом GZip поддерживает только следующие параметры: x, fb, pass.

BZip2

Параметр | Значение по умолчанию | Описание
x=[1 | 3 | 5 | 7 | 9 ] | 5 | Устанавливает уровень сжатия.
pass={NumPasses} | 1 | Устанавливает число проходов для Bzip2 кодера.
d={Size}[b|k|m] | 900000 | Устанавливает размер словаря для BZip2
mt=[off | on | {N}] | on | Устанавливает режим многопоточности.
x=[1 | 3 | 5 | 7 | 9 ]

Установки уровня сжатия

Уровень | Словарь | Число проходов | Описание
1 | 100000 | 1 | Скоростной
3 | 500000 | Быстрый
5 | 900000 | Нормальный
7 | 2 | Максимальный
9 | 7 | Ультра
d={Size}[b|k|m]

Установка размера словаря для BZip2. Вы должны определить размер в байтах, килобайтах, или Мегабайтах. Максимальное значение для размера словаря - 900000б. Если Вы не определите никакого символа из [b|k|m], то размер словаря будет вычислен как Размер_словаря = 2^Size байт.

pass={NumPasses}

Установка числа проходов. Оно может быть в диапазоне от 1 до 10. Значение по умолчанию - 1 для нормального режима, 2 для максимального режима и 7 для ультра режима. Большее число может дать немного лучшую степень сжатия и более медленный процесс сжатия.

mt=[off | on | {N}]

Установка режим многопоточности. Если Вы имеете многопроцессорную систему или многоядерную систему, Вы можете получить увеличение скорости, с этим ключом. Если Вы определяете {N}, например mt=4, 7-Zip пробуют использовать 4 потока.

7z

Параметр | Значение по умолчанию | Описание
x=[0 | 1 | 3 | 5 | 7 | 9 ] | 5 | Устанавливает уровень сжатия.
s=[off | on | [e] [{N}f] [{N}b | {N}k | {N}m | {N}g] ] | on | Устанавливает solid режим.
f=[off | on] | on | Включает или отключает фильтры сжатия для исполняемых файлов.
hc=[off | on] | on | Включает или отключает сжатие заголовка архива.
he=[off | on] | off | Допускает или отключает кодирование заголовка архива.
b{C1}[s{S1}]:{C2}[s{S2}] |  | Устанавливает связывание между кодерами.
{N}={MethodID}[:param1][:param2][..] | LZMA | Устанавливает метод: LZMA, LZMA2, PPMd, BZip2, Deflate, Delta, BCJ, BCJ2, Copy.
mt=[off | on | {N}] | on | Устанавливает режим многопоточности.
x=[0 | 1 | 3 | 5 | 7 | 9 ]

Установки уровня сжатия

Уровень | Метод | Словарь | Число быстрых байтов | Средство поиска соответствия | Фильтр | Описание
0 | Copy | Никакого сжатия.
1 | LZMA | 64 кб | 32 | HC4 | BCJ | Скоростное сжатие
3 | LZMA | 1 Мб | 32 | HC4 | BCJ | Быстрое сжатие
5 | LZMA | 16 Мб | 32 | BT4 | BCJ | Нормальное сжатие
7 | LZMA | 32 Мб | 64 | BT4 | BCJ | Максимальное сжатие
9 | LZMA | 64 Мб | 64 | BT4 | BCJ2 | Ультра сжатие

Примечание: "x" работает как "x=9".

s=[off | on | [e] [{N}f] [{N}b | {N}k | {N}m | {N}g] ]

Включает или отключает solid режим. По умолчанию режим s=on. В solid режиме файлы группируются друг с другом. Обычно сжатие в solid режиме улучшает степень сжатия.

e | Использует отдельный solid блок для каждого нового расширения файла
{N}f | Устанавливает предел для числа файлов в одном solid блоке
{N}b | {N}k | {N}m | {N}g | Устанавливает предел для полного размера solid блока в байтах

Это - пределы по умолчанию для размера solid блока:

Уровень сжатия | Размер solid блока
Сохранение | 0 б
Скоростной | 16 Мб
Быстрый | 128 Мб
Нормальный | 2 Гб
Максимальный | 4 Гб
Ультра | 4 Гб

Ограничение размера solid блока обычно уменьшает степень сжатия, но дает следующие преимущества:

  • Уменьшение потерь в случае будущего разрушения архива.
  • Уменьшение времени извлечения группы файлов (или только одного файла), если группа не содержит весь архив.

Обновление solid .7z архивов может быть медленным, так как, может потребоваться некоторое пересжатие.

Пример:

s=100f10m

устанавливает solid режим с ограничением по 100 файлов и по 10 Мб в одном solid блоке.

f=[off | on]

Включает или отключает фильтры сжатия для исполняемых файлов: dll, exe, ocx, sfx, sys. Это использует BCJ2 фильтр в режиме Ultra и BCJ фильтр в других режимах. По умолчанию режим f=on.

hc=[off | on]

Включает или отключает сжатие заголовка архива. По умолчанию режим hc=on. Если сжатие заголовка архива будет включено, то некоторые части заголовка архива будут сжаты с LZMA методом.

he=[off | on]

Включает или отключает кодирование заголовка архива. По умолчанию режим he=off.

{N}

Устанавливает порядок методов. Это используется также, чтобы связать параметры с методами. Номера должны начаться от 0. Метод, который имеет меньший номер, будет использоваться перед другими.

b{C1}[s{S1}]:{C2}[s{S2}]

Связывает выходной поток S1 в кодере C1 с входным потоком S2 в кодере C2. Если номер потока не будет определен, то будет использоваться поток с номером 0.

Обычно кодер имеет один входной поток и один выходной поток. В 7z некоторые кодеры могут иметь множественные потоки ввода и вывода.

Например, BCJ2 кодер имеет один входной поток и четыре выходных потока.

mt=[off | on | {N}]
Устанавливает режим многопоточности. Если Вы имеете многопроцессорную систему или многоядерную систему, Вы можете получить увеличение скорости, с этим ключом. 7-Zip поддерживает режим многопоточности только для сжатия LZMA/LZMA2 и сжатия/распаковки BZip2. Если Вы определяете {N}, например mt=4, 7-Zip пробуют использовать 4 потока. Сжатия LZMA использует только 2 потока.
{N}={MethodID}[:param1][:param2] ... [:paramN]

Устанавливает метод сжатия. Вы можете использовать любое число методов. По умолчанию метод LZMA.

Параметры должны быть в одной из следующих форм:

  • {ParamName}={ParamValue}.
  • {ParamName}{ParamValue}, если {ParamValue} - число, а {ParamName}, не содержит чисел.

Поддерживаемые методы:

ID метода | Описание
LZMA | Алгоритм, основанный на LZ алгоритме
LZMA2 | Алгоритм, основанный на LZMA алгоритме
PPMd | PPMdH Дмитрия Шкарина с небольшими изменениями
BZip2 | BWT алгоритм
Deflate | LZ+Huffman
Copy | Никакого сжатия

Поддерживаемые фильтры:

ID метода | Описание
Delta | Delta фильтр
BCJ | конвертер для x86 исполняемых программ
BCJ2 | конвертер для x86 исполняемых программ (версия 2)
ARM | конвертер для ARM (небольшая доводка) исполняемых программ
ARMT | конвертер для ARM Thumb (небольшая доводка) исполняемых программ
IA64 | конвертер для IA-64 исполняемых программ
PPC | конвертер для PowerPC (небольшая доводка) исполняемых программ
SPARC | конвертер для SPARC исполняемых программ

Фильтры увеличивают степень сжатия для некоторых типов файлов. Фильтры должны использоваться с одним из метода сжатия (например, BCJ + LZMA).

LZMA

LZMA - алгоритм, основанный на Lempel-Ziv алгоритме. Он обеспечивает очень быструю распаковку (приблизительно в 10-20 раз быстрее, чем сжатие). Требуемые объемы и конфигурации памяти для сжатия и распаковки, также различны (для подробностей см. описание ключа d={Size}[b|k|m]).

Параметр | Значение по умолчанию | Описание
a=[0|1] | 1 | Устанавливает режим сжатия
d={Size}[b|k|m] | 24 | Устанавливает размер словаря
mf={MF_ID} | bt4 | Устанавливает средство поиска
fb={N} | 32 | Устанавливает число быстрых байтов
mc={N} | 32 | Устанавливает число циклов для средства поиска
lc={N} | 3 | Устанавливает число буквенных контекстных битов - [0, 8]
lp={N} | 0 | Устанавливает число буквенных позиционных битов - [0, 4]
pb={N} | 2 | Устанавливает число позиционных битов - [0, 4]
a=[0|1]

Устанавливает режим сжатия: 0 = быстрое, 1 = нормальное. По умолчанию 1.

d={Size}[b|k|m]

Устанавливает размер словаря для LZMA. Вы должны определить размер в байтах, килобайтах, или Мегабайтах. Максимальное значение для размера словаря - 1 Гб = 2^30 байтов. Значение по умолчанию для LZMA - 24 (16 Мб) в нормальном режиме, 25 (32 Мб) в максимальном режиме (-mx=7) и 26 (64 Мб) в ультра режиме (-mx=9). Если Вы не определите никакой символ для установки [b|k|m], то размер словаря будет вычислен как Размер_словаря = 2^Size байтов. Для того чтобы распаковать файл, сжатый LZMA методом со словарем размером N, Вы нуждаетесь в N байтах доступной памяти (оперативная память).

mf={MF_ID}

Устанавливает средство поиска соответствия для LZMA. Метод по умолчанию - bt4. Алгоритмы из hc* группы не обеспечивают хорошую степень сжатия, но они часто работают довольно быстро в комбинации с быстрым способом (a=0). Требуемые объемы и конфигурации памяти зависят от размера словаря (параметр "d" в таблице ниже).

MF_ID | Словарь | Используемая память | Описание
bt2 | 9.5 * d | + 4 Мб | Binary Tree | 2 bytes hashing
bt3 | 11.5 * d | 3 bytes hashing
bt4 | 64 кб ... 48 Мб | 11.5 * d | 4 bytes hashing
64 Мб ... 1024 Мб | 10.5 * d
hc4 | 64 кб ... 48 Мб | 7.5 * d | Hash Chain
64 Мб ... 1024 Мб | 6.5 * d

Примечание: ваша операционная система также нуждается в некотором количестве физической памяти для внутренних целей. Так что сохраните, по крайней мере, 32 Мб физической памяти неиспользуемыми.

fb={N}

Устанавливает число быстрых байтов для LZMA. Оно может быть в диапазоне от 5 до 273. По умолчанию - 32 для нормального режима и 64 для максимального и ультра режимов. Обычно большее число дает немного лучшую степень сжатия и более медленный процесс сжатия.

mc={N}

Устанавливает число циклов (проходов) для средства поиска соответствия. Оно может быть в диапазоне от 0 до 1000000000. Значение по умолчанию - (16 + число_быстрых_байтов / 2) для средств поиска соответствия BT* и (8 + число_быстрых_байтов / 4) для средства поиска соответствия HC4. Если Вы определите mc=0, то LZMA будет использовать значение по умолчанию. Обычно большое число дает немного лучшую степень сжатия и более медленный процесс сжатия. Например, mf=HC4 и mc=10000 могут обеспечить почти ту же самую степень сжатия как mf=BT4.

lc={N}

Устанавливает число буквенных контекстных битов (старшие разряды предыдущей буквы). Оно может быть в диапазоне от 0 до 8. По умолчанию - 3. Иногда lc=4 дает выгоду для больших файлов.

lp={N}

Устанавливает число буквенных позиционных битов (младшие биты текущей позиции для букв). Оно может быть в диапазоне от 0 до 4. По умолчанию - 0. Ключ lp предназначен для периодических данных, когда период равен 2^value (где lp=value). Например, для 32-битовых (4-байтовых) периодических данных Вы можете использовать lp=2. Часто лучше установить lc=0, если Вы изменяете ключ lp.

pb={N}

Устанавливает число позиционных битов (младшие биты текущей позиции). Оно может быть в диапазоне от 0 до 4. По умолчанию - 2. Ключ pb предназначен для периодических данных, когда период равен 2^value (где lp=value).

LZMA2

LZMA2 - модифицированная версия LZMA. Она обеспечивает следующие преимущества перед LZMA:

  • Лучшая степень сжатия для данных которые не могут быть сжаты. LZMA2 может сохранить такие блоки данных в несжатой форме. Также такие данные будут быстрее распаковываться.
  • Лучше поддержка многопоточности. Если Вы сжимаете большой файл, LZMA2 может разбить этот файл на куски и сжать эти куски в несколько потоков.
Параметр | Значение по умолчанию | Описание
c={Size}[b|k|m] | dictSize * 4 | Устанавливает размер куска

Если Вы не определяете размер куска, LZMA2 устанавливает его в значение DictionarySize * 4.

LZMA2 также поддерживает все параметры LZMA, но lp+lc не может быть более чем 4.

Использование LZMA2: 1 поток для каждого куска в режимах x1 и x3; и 2 потока для каждого куска в режимах x5, x7 и x9. Если LZMA2 собирается использовать только такое число потоков, требуемых для одного куска, он не разбивает поток по кускам. Таким образом Вы можете получить различную степень сжатия для различного числа потоков. Вы можете получить лучшую степень сжатия, когда Вы используете 1 или 2 потока.

PPMd

PPMd - алгоритм, базируемый на PPM. Этот алгоритм главным образом основан на исходном коде PPMdH Дмитрия Шкарина. PPMd обеспечивает очень хорошую степень сжатия для простых текстовых файлов. Нет никакого различия между скоростью сжатия и скоростью распаковки. Требуемые объемы и конфигурации памяти для сжатия и распаковки также одинаковы.

Параметр | Значение по умолчанию | Описание
mem={Size}[b|k|m] | 24 | Устанавливает размер используемой памяти для PPMd.
o={Size} | 6 | Устанавливает порядок моделей для PPMd.
mem={Size}[b|k|m]

Устанавливает размер используемой памяти для PPMd. Вы должны определить размер в байтах, килобайтах, или Мегабайтах. Максимальное значение - 2Гб = 2^31 байтов. По умолчанию - 24 (16 Мб). Если Вы не будете определять никакого символа для установки [b|k|m], то размер памяти будет вычислен как (2^Size) байтов. PPMd использует одинаковый объем памяти для сжатия и распаковки.

o={Size}

Устанавливает порядок моделей для PPMd. Размер должен быть в диапазоне [2,32]. По умолчанию - 6.

BCJ2

BCJ2 - конвертер переходов для 32-разрядного x86 исполняемых программ (версия 2). Он преобразовывает некоторые команды перехода для того, чтобы увеличить дальнейшее сжатие.

BCJ2 кодер имеет один входной поток и четыре выходных потока:

  • s0: основной поток. Он требует дальнейшего сжатия.
  • s1: поток для преобразованных значений CALL. Он требует дальнейшего сжатия.
  • s2: поток для преобразованных значений JUMP. Он требует дальнейшего сжатия.
  • s3: сервисный поток. Он уже сжат.

Если используется LZMA, размер словаря для потоков s1 и s2 может быть намного меньшим (512 кб - достаточно для большинства случаев) чем размер словаря для потока s0.

Delta

Это позволяет установить дельта смещение в байтах. Например, чтобы сжать 16-битовые стерео WAV файлы, Вы можете установить "0=Delta:4". По умолчанию дельта смещение равно 1.

XZ

XZ теперь поддерживает только LZMA2 кодер. Ключи аналогичны ключам для 7z формата.

Примеры

7z a -tzip archive.zip *.jpg -mx0

добавляет *.jpg файлы в архив archive.zip без сжатия.

7z a -t7z archive.7z *.exe *.dll -m0=BCJ -m1=LZMA:d=21 -ms -mmt

добавляет *.exe и *.dll файлы в solid архив archive.7z используя LZMA метод с 2 Мб словарем и BCJ конвертером. Сжатие будет использовать многопоточную оптимизацию.

7z a -t7z archive.7z *.exe *.dll -m0=BCJ2 -m1=LZMA:d23 -m2=LZMA:d19 -m3=LZMA:d19
     -mb0:1 -mb0s1:2 -mb0s2:3

добавляет *.exe и *.dll файлы в архив archive.7z, используя BCJ2 конвертер, LZMA со словарем 8 Мб для основного выходного потока (s0), и LZMA со словарем 512 кб для s1 и s2 выходных потоков BCJ2.

7z a -t7z archive.7z *.txt -m0=PPMd

добавляет *.txt добавляет в архив archive.7z, используя PPMd метод.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), u (Update)

См. также

Ключи: -t (set Type of archive)


-o (Установить каталог адресат) ключ

-o (set Output directory) ключ

Определяет каталог адресат, куда файлы должны быть извлечены.

Этот ключ может использоваться только с командами извлечения.

Синтаксис

-o{dir_path}
{dir_path}
Это - путь каталога адресата. Он не обязательно должен заканчиваться обратным слешем. Если Вы определите * в {dir_path}, то 7-Zip заменит этот символ * на название архива.

Пример

7z x archive.zip -oc:\Doc

извлекает все файлы из архива archive.zip в каталог c:\Doc.

7z x *.zip -o*

извлекает все *.zip архивы в подкаталоги с именами этих архивов.

Команды, которые могут использоваться с этим ключом

e (Extract), x (Extract with full paths)


-p (Установить пароль) ключ

-p (set Password) ключ

Определяет пароль.

Синтаксис

-p{password}
{password}
Определяет пароль.

Примеры

7z a archive.7z -psecret -mhe *.txt

сжимает *.txt файлы в archive.7z используя пароль "secret". Это также зашифрует заголовки архива (ключ -mhe), таким образом, имена файлов будут зашифрованы.

7z x archive.zip -psecret

извлекает все файлы из archive.zip используя пароль "secret".

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), e (Extract), t (Test), u (Update), x (Extract with full paths)


-r (Рекурсия подкаталогов) ключ

-r (Recurse subdirectories) ключ

Определяет метод обработки подстановочных знаков и имен файла в командной строке.

Синтаксис

-r[- | 0]

Ключ | Описание
-r | Допустить рекурсию подкаталогов.
-r- | Отключить рекурсию подкаталогов. Эта опция - по умолчанию для всех команд.
-r0 | Допустить рекурсию подкаталогов только для имен подстановочных знаков.

Примеры

7z l archive.zip *.doc -r-

составляет список всех *.doc файлов, которые принадлежат корневому каталогу архива в архиве archive.zip.

7z a -tzip archive.zip -r src\*.cpp src\*.h

добавляет все *.cpp и *.h файлы из каталога src и всех его подкаталогов в архив archive.zip.

7z a archive.7z folder1\

добавляет все файлы из каталога folder1 и всех его подкаталогов в архив archive.7z.

7z a archive.7z -r folder2\

ищет все каталоги folder2 во всех подкаталогах, и добавляет их (включая все подкаталоги) в архив archive.7z.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), e (Extract), l (List), t (Test), u (Update), x (Extract with full paths)

См. также

Ключи: -i (Include), -x (Exclude)


-scc (Set charset for console input/output) switch

-scc (Set charset for console input/output) ключ

Устанавливает кодировку для ввода/вывода в консоли.

Синтаксис

-scc{UTF-8 | WIN | DOS}

По умолчанию кодировка - DOS.

UTF-8
Устанавливает кодировку Unicode UTF-8.
WIN
Устанавливает кодировку, используемую Windows по умолчанию.
DOS
Устанавливает кодировку, используемую Windows в DOS (OEM) по умолчанию.

Пример

7z l archive.7z -sccUTF-8

выведет список файлов из archive.7z в кодировке UTF-8.


-scs (Установить кодировку для файл-списка) ключ

-scs (Set charset for list files) ключ

Устанавливает кодировку для файл-списка.

Синтаксис

-scs{UTF-8 | WIN | DOS}

По умолчанию кодировка - UTF-8.

UTF-8
Устанавливает кодировку Unicode UTF-8.
WIN
Устанавливает кодировку, используемую Windows по умолчанию.
DOS
Устанавливает кодировку, используемую Windows в DOS (OEM) по умолчанию.

Пример

7z a archive.7z @listfile.txt -scsWIN

упаковывает файлы из файл-списка listfile.txt, который содержит список файлов в кодировке, используемой Windows по умолчанию.

Команды, которые могут использоваться с этим ключом

a (Add), u (Update)


-seml (Переслать архив по почте) ключ

-seml (Send archive by email) ключ

Посылает архив по электронной почте.

Синтаксис

-seml[.]
[.]
Заставляет архив быть удаленным после присоединения его копии к сообщению электронной почты.

Пример

7z a archive.7z -seml a.txt

упаковывает файл a.txt и посылает его в виде archive.7z, используя электронную почту.

Команды, которые могут использоваться с этим ключом

a (Add), u (Update)


-sfx (Создать SFX архив) ключ

-sfx (Create SFX archive) ключ

Создает само-извлекающийся архив.

Синтаксис

-sfx[{SFX_Module}]
{SFX_Module}

Определяет SFX модуль, который будет объединен с архивом. Этот модуль должен быть помещен в тот же самый каталог, как и 7z.exe. Если {SFX_Module} не будет назначен, то 7-Zip будет использовать стандартный консольный SFX модуль 7zCon.sfx.

SFX_Module | Описание
7z.sfx | Windows версия.
7zCon.sfx | Консольная версия.
7zS.sfx | Windows версия для инсталляторов.
7zSD.sfx | Windows версия для инсталляторов (использует MSVCRT.dll).

Все SFX модули распакованы. Вы можете использовать программу UPX (http://upx.sourceforge.net) для сжатия таких модулей. После сжатия программой UPX размер sfx модуля будет уменьшен до 40-50 % его первоначального размера.

SFX модули для инсталляторов

SFX модули для инсталляторов включены во внешний пакет (7z_extra). Вы можете загрузить эти модули с www.7-zip.org. SFX модули для инсталляторов (7zS.sfx и 7zSD.sfx) позволяют Вам создавать вашу собственную инсталляционную программу. Такой модуль извлекает архив во временную папку пользователя, затем выполняет указанную программу и удаляет временные файлы после окончания программы. Само-извлекающий архив для инсталляторов должен быть создан как соединение 3-х файлов: SFX_Module, Installer_Config, 7z_Archive. Кроме того допускается использование дополнительного файла Installer_Config. Вы можете использовать следующую команду, чтобы создать само-извлекающийся архив - инсталлятор:

copy /b 7zS.sfx + config.txt + archive.7z archive.exe

Оптимально маленький размер инсталляционного пакета может быть достигнут, если инсталляционные файлы были распакованы перед включением их в 7z архив.

Ключ -y для модуля инсталлятора определяет тихий режим для извлечения.

Формат файла конфигурации инсталлятора

Этот файл конфигурации содержит команды для инсталлятора. Файл начинается со строки ;!@Install@!UTF-8! и заканчивается ;!@InstallEnd@!. Файл должен быть написан в кодировке UTF-8. Файл содержит любые или все из этих строковых пар:

ID_String="Value"

ID_String | Описаниее
Title | Заголовок для сообщений
BeginPrompt | Начальное сообщение подсказки
Progress | Значение может быть "yes" или "no". Значение по умолчанию - "yes".
RunProgram | Команда для выполнения. Значение по умолчанию - "setup.exe". Подстрока %%T будет заменена путем к временной папке, куда были извлечены файлы
Directory | Префикс директории для "RunProgram". Значение по умолчанию - ".\\"
ExecuteFile | Имя файла для исполнения
ExecuteParameters | Параметры для "ExecuteFile"

Вы можете опустить любую пару.

Есть два пути выполнить инсталляционную программу: RunProgram и ExecuteFile. Используйте RunProgram, если вы хотите выполнить программу из .7z архива. Используйте ExecuteFile, если вы хотите открыть документ из .7z архива или, если вы хотите выполнить команду из Windows.

Если вы используете RunProgram, и установили пустой префикс директории: Directory="", система будет искать исполняемый файл в следующей последовательности:

  1. Директория, из которой приложение (инсталлятор) загружено.
  2. Временная директория, куда были распакованы файлы.
  3. Системная директория Windows.

Пример файла конфигурации

;!@Install@!UTF-8!
Title="7-Zip 4.00"
BeginPrompt="Do you want to install the 7-Zip 4.00?"
RunProgram="setup.exe"
;!@InstallEnd@!

;!@Install@!UTF-8!
Title="7-Zip 4.00"
BeginPrompt="Do you want to install the 7-Zip 4.00?"
ExecuteFile="7zip.msi"
;!@InstallEnd@!

;!@Install@!UTF-8!
Title="7-Zip 4.01 Update"
BeginPrompt="Do you want to install the 7-Zip 4.01 Update?"
ExecuteFile="msiexec.exe"
ExecuteParameters="/i 7zip.msi REINSTALL=ALL REINSTALLMODE=vomus"
;!@InstallEnd@!

Примеры

7z a -sfx a.exe *.txt

добавляет *.txt файлы в само-извлекающий архив a.exe, используя по умолчанию консольный SFX модуль.

7z a -sfx7z.sfx a.exe *

добавляют все файлы в само-извлекающий архив a.exe с модулем 7z.sfx, используя Windows версию SFX модуля.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), u (Update),


-si (Читать данные из stdin) ключ

-si (read data from stdin) ключ

Заставляет 7-Zip, читать данные из stdin (стандартный ввод) вместо дисковых файлов.

Синтаксис

-si{file_name}
{file_name}
Определяет имя, под которым будут сохранены в архиве сжатые данные. Если file_name не будет определено, то данные будут сохранены без имени.

Примечание: текущая версия 7-Zip поддерживает чтение архивов из stdin только для xz, lzma, tar, gzip и bzip2 архивов.

Примеры

7z a archive.gz -tgzip -siDoc2.txt < Doc.txt

упаковывает входящий поток из файла Doc.txt в архив archive.gz, используя имя файла Doc2.txt.

7z x 7z905.tar.gz -so | 7z x -si -ttar

распаковывает архив tar.gz.

Команды, которые могут использоваться с этим ключом

a (Add), e (Extract), u (Update), x (Extract with full paths)


-so (Записывать данные в stdout) ключ

-so (write data to stdout) ключ

Заставляет 7-Zip, записывать данные в stdout (стандартный поток вывода).

Синтаксис

-so

Примеры

7z x archive.gz -so > Doc.txt

распаковывает архив archive.gz в выходной поток и затем переадресовывает этот поток в файл Doc.txt.

7z a dummy -tgzip -so Doc.txt > archive.gz

упаковывает файл Doc.txt в стандартный выходной поток 7-Zip и записывает этот поток в файл archive.gz.

Команды, которые могут использоваться с этим ключом

a (Add), e (Extract), u (Update), x (Extract with full paths)


-slp (Установить режим больших страниц) ключ

-slp (Set Large Pages mode) ключ

Устанавливает режим больших страниц.

Синтаксис

-slp[-]

Ключ | Описание
-slp | Позволяет режим больших страниц.
-slp- | Отключает режим больших страниц. Эта опция - по умолчанию для всех команд.

Режим больших страниц увеличивает скорость сжатия. Однако, есть пауза в начале сжатия, в то время когда 7-Zip распределяет большие страницы в памяти. Если 7-Zip не может разместить большие страницы, он размещает обычные маленькие страницы. Кроме того, Диспетчер задач не показывает реальное использование памяти программами, если 7-Zip используют большие страницы. Эта особенность работает только на Windows 2003 / XP x64. Также Вы должны иметь права администратора для вашей системы. Рекомендованный размер оперативной памяти для этой особенности - 1 Гб или больше. Чтобы установить эту особенность, Вы должны запустить 7-Zip Менеджер файлов, по крайней мере, один раз, закрыть его и перезагрузить систему.

Ваша система может зависнуть на несколько секунд при запуске сжатия, если Вы используете режим -slp. Таким образом не рекомендуют использовать режим -slp, для сжатия небольших объемов данных (менее 100 Мб).

Пример

7z a archive.7z -slp a.iso

упаковывает файл a.iso с включенным режимом больших страниц.


-slt (Показывать техническую информацию) ключ

-slt (Show technical information) ключ

Устанавливает технический режим для команды l (List).

Синтаксис

-slt

Пример

7z l -slt archive.7z

показывает подробную техническую информацию о файлах в archive.7z.

Команды, которые могут использоваться с этим ключом

l (List)


-ssc (Установить режим регистрозависимости) ключ

-ssc (Set Sensitive Case mode) ключ

Устанавливает режим чувствительности к регистру символов для имен файлов.

Синтаксис

-scs[-]

Ключ | Описание
-ssc | Устанавливает режим с учетом регистра. Это - значение по умолчанию для Posix/Linux систем.
-ssc- | Устанавливает режим без учета регистра. Это - значение по умолчанию для Windows систем.

Пример

7z a archive.7z A*.txt -ssc -r

упаковывает все файлы A*.txt из текущего каталога и всех его - подкаталогов. Эта команда не упаковывает файлы a*.txt.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), e (Extract), l (List), t (Test), u (Update), x (Extract with full paths)


-ssw (Упаковывать файлы открытые для записи) ключ

-ssw (Compress files open for writing) ключ

Упаковывает файлы открытые для записи другим приложением. Если этот ключ не установлен, 7-Zip не включает такие файлы в архив.

Синтаксис

-ssw

Пример

7z a archive.7z -ssw *.txt

упаковывает все *.txt файлы в текущей папке, включая файлы открытые для записи другим приложениями.

Команды, которые могут использоваться с этим ключом

a (Add), u (Update)


-t (Установить тип архива) ключ

-t (set Type of archive) ключ

Определяет тип архива.

Синтаксис

-t{archive_type}
{archive_type}
Определяет тип архива. Это может быть: *, 7z, split, zip, gzip, bzip2, tar, ... , или их сочетание, как: mbr.vhd

Если ключ -t{archive_type} не определен, то 7-Zip использует расширение имени файла архива для определения типа архива. Если Вы создаете новый архив, ключ -t{archive_type} не определен и не указано расширение архива, то 7-Zip будет создавать .7z архив.

Когда Вы извлекаете архив некоторых типов, который содержит другой архив без сжатия (например, MBR в VHD), 7-Zip может открыть оба уровня за один шаг. Если Вы хотите открыться/извлечь только архив верхнего уровня, то используйте ключ -t*.

Примечание: форматы gzip или bzip2 поддерживают только один файл в архиве. Если Вы хотите сжать больше чем один файл с этими форматами, создайте прежде tar архив, а затем сожмите его с вашим выбранным форматом.

Пример

7z a -tzip archive.zip *.txt

добавляет все *.txt файлы из текущего каталога в архив archive.zip.

7z t -t7z.split archive.7z.001

тестирует все файлы в archive.7z.001. Это также проверяет, что архив является многотомным .7z архивом.

7z x -tiso archive.iso

извлекает файлы из archive.iso, открывая его как ISO архив.

7z x -tudf archive.iso

извлекает файлы из archive.iso, открывая его как UDF архив.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), e (Extract), l (List), t (Test), u (Update), x (Extract with full paths)


-u (Опции обновления) ключ

-u (Update options) ключ

Определяет, как обновить файлы в архиве и (или) как создать новые архивы.

Синтаксис

-u[-]<action_set>[!{new_archive_name}]

  <action_set> ::= <state_action>...

    <state_action> ::= <state><action>

      <state> ::= p | q | r | x | y | z | w

      <action> ::= 0 | 1 | 2 | 3

Параметры

dash (-)

Отключает любые обновления в базовом архиве.

Термин базовый архив означает архив, назначенный "base_archive_name" в командной строке. Для подробностей см. синтаксис Командной строки

{new_archive_name}

Определяет имя-путь нового архива, который будет создан. Все опции в этом ключе относятся к этому новому архиву.

Если не назначен, то все опции в этом ключе относятся к основному архиву команды.

<state>

Определяет состояние специфического файла, который будет обработан.

<state> ::= p | q | r | x | y | z | w

Для каждого уникального имени файла есть 6 вариантов состояния:

<state> | Формулировка условия | Файл на диске | Файл в архиве
p | Файл существует в архиве, но не соответствует подстановочными знаками. | Существует, но не соответствует
q | Файл существует в архиве, но не существует на диске. | Не существует | Существует
r | Файл не существует в архиве, но существует на диске. | Существует | Не существует
x | Файл в архиве более новый, чем файл на диске. | Старее | Более новый
y | Файл в архиве старее, чем файл на диске. | Более новый | Старее
z | Файл в архиве - такой же, как файл на диске | То же самое | То же самое
w Не может быть обнаружен, какой более новый файл (времена - те же самые, размеры отличны) ? ?
<action>

Определяет действие для данного <state>.

<action> ::= 0 | 1 | 2 | 3

Для каждого состояния Вы можете определить один из трех вариантов действий:

<action> | Описание
0 | Игнорировать файл (не создавайте пункт в новом архиве для этого файла)
1 | Копировать файл (копируют из старого архива в новый)
2 | Упаковать (сжимают файл с диска в новый архив)
3 | Создать Анти-пункт (пункт, который удалит файл или каталог в ходе извлечения). Эта функция поддержана только в 7z формате.

Замечания

Любая команда обновления (типа a (Add), d (Delete), u (Update)) может быть назначена в этих условиях.

Следующая таблица показывает установки действий для команд обновления.

команда \ <state> | p | q | r | x | y | z | w
d (Delete) | 1 | 0 | 0 | 0 | 0 | 0 | 0
a (Add) | 1 | 1 | 2 | 2 | 2 | 2 | 2
u (Update) | 1 | 1 | 2 | 1 | 2 | 1 | 2
Freshen | 1 | 1 | 0 | 1 | 2 | 1 | 2
Synchronize | 1 | 0 | 2 | 1 | 2 | 1 | 2

Если Вы не определяете опцию !{new_archive_name}, тогда все опции будут относиться к основному архиву (архив, назначенный в командной строке после 7z команды). Если Вы определяете опцию !{new_archive_name}, тогда 7-Zip также создаст новый архив с указанным именем, и все опции будут относиться к этому новому архиву.

Множественные ключи обновления поддержаны. 7-Zip может создать любое число новых архивов в ходе одной операции.

По умолчанию, набор действий для каждого нового архива назначен как набор действий основной команды. Есть 3 различные набора действий для команд: a (Add), d (Delete), u (Update). Вы можете перезагрузить любую пару <state_action>.

Примечания часового пояса

Если Вы изменяете часовой пояс (когда Вы перемещаете свой компьютер в другой часовой пояс или, если перевели часы на летнее/зимнее время, принятое в Вашем поясе), у Вас могут быть некоторые проблемы с командами обновления, которые зависят от времени модификации файла. Настоятельно рекомендуется использовать только файловую систему, которая использует Координированное среднее гринвичское время (Coordinated Universal Time) (UTC) и формат архива, который также использует UTC. В этом случае у Вас не будет никаких проблем с изменениями часового пояса. Также рекомендуется использовать только форматы UTC в других случаях, например, если Вы посылаете файлы кому-то в другом часовом поясе.

Также в некоторых случаях нет никаких проблем, если и файловая система и формат архива используют местное время, например, файловую систему FAT и формат ZIP.

  • UTC файловая система: NTFS
  • UTC форматы архивов: zip с ключом -mtc, 7z, tar, gzip2, iso, wim
  • Файловая система местного времени: FAT, FAT32
  • Форматы архивов местного времени: rar, zip, cab

Примеры

7z u c:\1\exist.7z -u- -up0q3x2z0!c:\1\update.7z *

создает новый архив update.7z и записывает в этот архив все файлы из текущего каталога, которые отличается от файлов в архиве exist.7z. Архив exist.7z изменен не будет.

7z u c:\1\exist.7z -up0q3x2z0!c:\1\update.7z * -ms=off

создает новый архив update.7z и записывает в этот архив все файлы из текущего каталога, которые отличается от файлов в архиве exist.7z.

Примечание: обновление solid .7z архивов может быть медленным, так как, может потребоваться некоторое пересжатие.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), u (Update),


-v (Создать тома) ключ

-v (Create Volumes) ключ

Определяет размеры томов.

Синтаксис

-v{Size}[b | k | m | g]
{Size}[b | k | m | g]
Определяет размеры томов в байтах, килобайтах (1 килобайт = 1024 байта), Мегабайтах (1 Мегабайт = 1024 килобайта) или Гигабайтах (1 Гигабайт = 1024 Мегабайта). Если Вы определяете только {Size}, 7-zip обработают его как байты.

Можно определить несколько ключей -v.

Примечание: Пожалуйста, не используйте тома (и не копируйте тома) до окончания архивирования. 7-Zip может изменить любые тома (включая первые тома) в конце архивирования.

Пример

7z a a.7z *.txt -v10k -v15k -v2m

создает многотомный архив a.7z. Первый том будет 10 кб, второй будет 15 кб, а все другие будут 2 Мб.

Команды, которые могут использоваться с этим ключом

a (Add),


-w (Установить рабочий каталог) ключ

-w (set Working directory) ключ

Устанавливает рабочий каталог для временного базового архива. По умолчанию, 7-Zip строит новый базовый файл архива в том же самом каталоге, где и старый базовый файл архива. Определяя этот ключ, Вы можете установить рабочий каталог, где будет построен временный базовый файл архива. После того, как временный базовый файл архива построен, он копируется поверх первоначального; затем временный файл удаляется.

Синтаксис

-w[{dir_path}]
{dir_path}

Определяет путь каталога адресата. Не требуется, что бы путь заканчивался обратным слешем.

Если <dir_path> не назначен, то 7-Zip будет использовать временный каталог Windows.

Пример

7z a -tzip archive.zip *.cpp -wc:\temp

добавляет *.cpp файлы в архив archive.zip, создавая временный архив в папке c:\temp.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), u (Update),


-x (Исключить имена файлов) ключ

-x (Exclude filenames) ключ

Определяет, какие имена файлов или имена с подстановочными знаками должны быть исключены из операции.

Множественные исключающие ключи, поддержаны.

Синтаксис

-x[<recurse_type>]<file_ref>

<recurse_type> ::= r[- | 0]
<file_ref> ::= @{listfile} | !{wildcard}

См. описание ключа -i (Include) для информации о параметрах опции.

Пример

7z a -tzip archive.zip *.txt -x!temp.*

добавляет к архиву archive.zip все *.txt файлы, кроме temp.* файлов.

Команды, которые могут использоваться с этим ключом

a (Add), d (Delete), e (Extract), l (List), t (Test), u (Update), x (Extract with full paths)

См. также

Ключи: -r (Recurse), -i (Include)


-y (Отвечать Да на все вопросы) ключ

-y (assume Yes on all queries) ключ

Отключает большинство нормальных пользовательских запросов в ходе выполнения 7-Zip. Вы можете использовать этот ключ, чтобы подавить запросы о перезаписи в командах e (Extract) и x (Extract with full paths).

Синтаксис

-y

Пример

7z x src.zip -y

извлекает все файлы из архива src.zip. Все запросы о перезаписи будут подавлены и файлы на диске с теми же самыми именами как в архиве будут перезаписаны.

Команды, которые могут использоваться с этим ключом

e (Extract), x (Extract with full paths)

См. также

Ключи: -ao (Overwrite mode),